Closed Bug 880741 Opened 6 years ago Closed 6 years ago

add indexedDB to frameworker API

Categories

(Firefox Graveyard :: SocialAPI, defect)

defect
Not set

Tracking

(firefox23 fixed, firefox24 fixed)

RESOLVED FIXED
Firefox 24
Tracking Status
firefox23 --- fixed
firefox24 --- fixed

People

(Reporter: Gavin, Assigned: mixedpuppy)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

IndexedDB is "better" than localStorage and is likely to be added to SharedWorkers, so we should let social providers use it in their workers.
Attached patch indexeddb patchSplinter Review
Assignee: nobody → mixedpuppy
Attachment #759848 - Flags: review?(gavin.sharp)
Comment on attachment 759848 [details] [diff] [review]
indexeddb patch

thanks!
Attachment #759848 - Flags: review?(gavin.sharp) → review+
https://hg.mozilla.org/mozilla-central/rev/7e181e566679
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Comment on attachment 759848 [details] [diff] [review]
indexeddb patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 879658
User impact if declined: no user impact. the earlier we can get indexeddb into use, the earlier we can at least mark localstorage as deprecated for socialapi workers (if not blocked)
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #759848 - Flags: approval-mozilla-aurora?
Comment on attachment 759848 [details] [diff] [review]
indexeddb patch

Seems low risk, we won't track but will approve.
Attachment #759848 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Deprioritizing for verification since it looks like this landed with tests in-testsuite. Please drop the [qa-] tag and add the verifyme keyword if there's testing required by QA here.
Flags: in-testsuite+
Whiteboard: [qa-]
Depends on: 935457
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.