[Camera] Camera app UI sticks to pick activity

RESOLVED WORKSFORME

Status

P1
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Unassigned)

Tracking

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: TaipeiWW)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
1. Title : Camera app UI sticks to pick activity UI
2. Precondition : Camera app should be working
3. Tester's Action : 1. Open camera from home screen-> minimize by pressing Home button
                     2. Open camera from pick activity (say wallpaper) -> cancel the pick activity by pressing X button
                     3. Reopen the main camera app
 
4. Detailed Symptom (ENG.) : main Camera app will have pick activity UI when it is reopened after cancelling the wallpaper/attachment pick activity

5. Expected : Camera UI should be proper.
6.Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: a25fb6bd1b0284ce3e197e88567d433c7815ee52
9.Personal email id: gjyothiprasad@gmail.com
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo?
(Reporter)

Updated

5 years ago
blocking-b2g: leo? → leo+
Target Milestone: --- → 1.1 QE3 (24jun)
Unable to reproduce with gaia master and version a25fb6bd1b0284ce3e197e88567d433c7815ee52 in Inari. Needs QA for reproduce it.
Keywords: qawanted
(Reporter)

Updated

5 years ago
Priority: -- → P1
Dale - Is this bug a dupe of bug 882107?
Flags: needinfo?(dale)

Comment 3

5 years ago
The issue does not reproduce on 6/17 b2g18 builds including Unagi, Inari, Buri devices

- main Camera app opens properly, does not have pick activity UI when it is reopened after cancelling the wallpaper/attachment pick activity

Build info:
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f1b84d841ced
Gaia   9dd0acc74c8e04218749917c85367a8080fa3cb1
Build  21030617070209
Version 18.1
Keywords: qawanted
Closing as works for me per above testing.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(dale)
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

5 years ago
Created attachment 763999 [details]
Video Attachment

This issue is still reproducible.
I have reproduced this issue in loe device with commit ID: 20c8fb29caf13e5a4530ba5c7b837a849c79c91b.

I am reopening this issue. Please check
Flags: needinfo?(jsmith)
(Reporter)

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

5 years ago
Also, Please let me know if any changes were made after 20c8fb29caf13e5a4530ba5c7b837a849c79c91b.
I still can't reproduce it with gaia version 20c8fb29caf13e5a4530ba5c7b837a849c79c91b in Inari.
What build ID does that commit have?
Flags: needinfo?(jsmith)
Does this a device depending issue?? If yes, please include Gecko version information...
(Reporter)

Comment 10

5 years ago
I am using following versions:
Gaia: cd68aa09fed7f8343b15a7f234e16b59ce562aea
Gecko: b518de015ff9d28c7a59a9f1e799fc0ec688024e
buid ID: 20130607202028
platform version: 18.0

Comment 11

5 years ago
i cannot reproduce it with a newer build.

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/8d0562d20324
Gaia   8c64e19b82d4e0490a7780232d3d6bd07d0ba9ec
BuildID 20130611074722
Version 18.0

Let me clarify the issue.
The expected result is a full screen camera preview with a tool bar at bottom.
On your leo device, when the camera launches at the last step, there is a bar for previewing photos you took shown on the top, and you expect the bar shouldn't be there. Is that your issue?

Comment 12

5 years ago
Please check the comment 11.

If you take a photo at step 1 before pressing home key, there will be a bar with preview shown at the last step.
However, you can hide the bar by clicking the screen again.

I believe it aligned the design.
Close it as WFM please if you agree so, LEO.
Flags: needinfo?(leo.bugzilla.gaia)
Al Tsai, 

There are two mode in Camera app: normal and pick activity. They look similar but with different tool bar at bottom. The most different part is, pick activity mode has a cross at the bottom-left, but normal mode has a grid at the same place. The step 1 and 3 should be normal mode, and step 2 should be pick activity mode.

According to video, the last step runs at pick activity mode. It is the issue of this bug.
(Reporter)

Comment 14

5 years ago
(In reply to John Hu [:johnhu] from comment #13)
> Al Tsai, 
> 
> There are two mode in Camera app: normal and pick activity. They look
> similar but with different tool bar at bottom. The most different part is,
> pick activity mode has a cross at the bottom-left, but normal mode has a
> grid at the same place. The step 1 and 3 should be normal mode, and step 2
> should be pick activity mode.
> 
> According to video, the last step runs at pick activity mode. It is the
> issue of this bug.

Yes, above mentioned is the issue scenario.
We can't close this issue.
Flags: needinfo?(leo.bugzilla.gaia)
leo, a fix for camera activities landed in gaia as per bug 882107 comment 3; please confirm that you can reproduce this issue on a device with that patch applied.
Flags: needinfo?(leo.bugzilla.gaia)

Comment 16

5 years ago
Thanks for correcting.
As John's comment in Comment 13, I cannot see the pick activity mode on my device.
Taipei's 0611 build does not show this bug and shown to partner. Partner to check on their side with latest build.
Whiteboard: TaipeiWW
Seems to be a problem with partner's gecko version.
Hi Wayne, thank you for the information.
It's not reproducible When I tried to reproduce this with our new binary which is based on AU 131. I guess there is some change on Gecko effected this and it is applied on AU 131 which corresponds to the Mozilla build ID: 20130616070209.
So, We can close it now.
Flags: needinfo?(leo.bugzilla.gaia)

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.