Closed Bug 88140 Opened 21 years ago Closed 13 years ago

'tabindex' attribute of OBJECT element not working

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: christinehoff4, Assigned: MatsPalmgren_bugz)

References

(Blocks 1 open bug, )

Details

(Keywords: access, Whiteboard: [tabbing])

Attachments

(6 files, 1 obsolete file)

Testing with the following builds:

Win98:  06_26_06_trunk
Mac:    06_27_03
Linux:  06_20_06_trunk

Save attached file and images to your local computer or go to the internal URL 
sight above.

Expected result: Tabbing should tab through the objects as indicated
Actual result: 'tabindex' attribute of OBJECT element not working.

I am filing this as a separate bug from #72870 which deals with the 'tabindex' 
attribute of the AREA element (when used with an object).
Attached image 1st of 4 images
Attached image 2nd of 4 images
Attached image 3rd of 4 images
Attached image 4th of 4 images
It doesn't make sense to me that the OBJECT element should support tabbing when
there's nothing to activate.  However, the HTML spec really isn't clear on the
subject.  We should probably raise it on www-html or something:

http://www.w3.org/TR/html4/interact/forms.html#h-17.11.1
Assignee: clayton → aaronl
Component: HTML Element → Keyboard Navigation
QA Contact: bsharma → sairuh
-> bryner, who understands our tabindex problems
Assignee: aaronl → bryner
Blocks: focusnav
Status: NEW → ASSIGNED
Summary: 'tabindex' attribute of OBJECT element not working → [tabbing] 'tabindex' attribute of OBJECT element not working
Target Milestone: --- → mozilla0.9.4
moving these out to 0.9.5 since it doesn't look like I will have time for 0.9.4.
Target Milestone: mozilla0.9.4 → mozilla0.9.5
Mass-moving lower-priority 0.9.5 bugs off to 0.9.6 to make way for remaining
0.9.4/eMojo bugs, and MachV planning, performance and feature work. If you
disagree with any of these targets, please let me know.
Target Milestone: mozilla0.9.5 → mozilla0.9.6
Since we're not clear on the desired behavior, I'm push to 0.9.7
Summary: [tabbing] 'tabindex' attribute of OBJECT element not working → 'tabindex' attribute of OBJECT element not working
Whiteboard: [tabbing]
Target Milestone: mozilla0.9.6 → mozilla0.9.7
Doesn't look like there has been any progress on determining what the behavior
should be for this.
Target Milestone: mozilla0.9.7 → mozilla1.2
I don't know how tabbing works internally, but if it uses
HTMLObjectElement.tabIndex,
then the fix for bug 95476 might have fixed this as well. Same for bug 72870.
Attached file Html with image displayed (obsolete) —
Using bugzilla link to display image. More clear.
Though maybe we don't need to tab into object element, but we should make the 
tab behavior correct.
Please try attachment 78827 [details], you will find if you try to tab into object 
element, you will not tab back to anything. That's mean the focus lost and can 
not retrieve back by keybord. I have to use mouse...
Also see bug 93149 - unable to tab between plugin and browser.
I can't get it to tab to the objects at all - which makes me think this is a dup
of 93149.
I can't get it to tab to the objects at all - which makes me think this is a dup
of bug 93149.
bug 162723 (which is a dupe of this bug) has a better testcase:
http://bugzilla.mozilla.org/attachment.cgi?id=95289&action=view showing that
<object>s with a tabindex actually do get focus, the focus then just doesn't
want to leave the object anymore.
*** Bug 162723 has been marked as a duplicate of this bug. ***
-- updated the url above as the previous one was not working fine.
when you visit the url and tab you see that you are able to tab to the image but
cannot tab out of the image as mentioned in comment #14.

Need traction on this bug.
adt: nsbeta1-
Keywords: nsbeta1nsbeta1-
*** Bug 186496 has been marked as a duplicate of this bug. ***
Assignee: bryner → nobody
Status: ASSIGNED → NEW
QA Contact: bugzilla → keyboard.navigation
Target Milestone: mozilla1.2alpha → ---
Assignee: nobody → mats.palmgren
Keywords: access
Corrected the image URLs in the last testcase.
Attachment #78827 - Attachment is obsolete: true
Both testcases works for me, Firefox 3.5.2 and trunk on Linux.

-> WORKSFORME
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.