Defect - Horizontal scroll bar blocks values in richlistbox popup menus

VERIFIED FIXED in Firefox 25

Status

defect
P1
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: kjozwiak, Assigned: jimm)

Tracking

unspecified
Firefox 25
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=defect c=Content_features u=metro_firefox_user p=1)

Attachments

(4 attachments)

When selecting the "username" field in Facebook, you will have a "scroll bar" that will be partially blocking the value. This doesn't look aesthetically pleasing and makes it very difficult to select the value from the drop down menu. Reproduced this issue on two different machines.

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to facebook.com and login
3) Once logged in, log out of Facebook and close Firefox Metro
4) Re-open Firefox Metro and go back to facebook.com
5) Select the "username" field and you will notice that the scroll bar will be partially blocking the value in the drop down menu

Current Behavior:

- Currently for some websites (Facebook in this instance), the scroll bar is blocking the value in the drop down menu

Expected Behavior:

- The drop down menu should be clean, easy to read and the user should see the value clearly without any issues

Using the following build to reproduce the issue:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-06-11-08-12-24-mozilla-central/
Blocks: 775718
No longer blocks: 831977
Priority: -- → P1
Summary: Defect - Scroll bar partially blocking the Facebook username drop down value → Defect - Horizontal scroll bar blocks values in richlistbox popup menus
Posted patch fixSplinter Review
Assignee: nobody → jmathies
Attachment #770104 - Flags: review?(rsilveira)
Whiteboard: feature=defect c=Content_features u=metro_firefox_user p=0 → feature=defect c=Content_features u=metro_firefox_user p=1
Blocks: metrov1it10
No longer blocks: metrov1defect&change
Status: NEW → ASSIGNED
QA Contact: jbecerra
Comment on attachment 770104 [details] [diff] [review]
fix

Review of attachment 770104 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Attachment #770104 - Flags: review?(rsilveira) → review+
https://hg.mozilla.org/mozilla-central/rev/aa1e79fea97e
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Duplicate of this bug: 888376
Posted patch select popupSplinter Review
missed one!
Attachment #773909 - Flags: review?(rsilveira)
Note, I filed bug 892449 on getting rid of this css file for good.
Depends on: 892449
Comment on attachment 773909 [details] [diff] [review]
select popup

Review of attachment 773909 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Attachment #773909 - Flags: review?(rsilveira) → review+
Posted image screenshot
Now, it doesn't display the scrollbar in the input suggestions box at all and the username (email address) is misaligned horizontally (extra space at the begining and only the first letters are visible) 
See attached screenshot.

Do you want me to log a new issue for this or just reopen this one?
Flags: needinfo?(jmathies)
(In reply to Mihaela Velimiroviciu [QA] (:mihaelav) from comment #10)
> Created attachment 776323 [details]
> screenshot
> 
> Now, it doesn't display the scrollbar in the input suggestions box at all
> and the username (email address) is misaligned horizontally (extra space at
> the begining and only the first letters are visible) 
> See attached screenshot.
> 
> Do you want me to log a new issue for this or just reopen this one?

Some menu work landed recently, mind checking for a regression range? I'm using a build from mc tip yesterday morning and I don't see this at all. Either way, I lets file a follow up. Doesn't look related to the auto-complete menu change which landed 2013-07-03.
Flags: needinfo?(jmathies)
This might also be language related. You might try spot checking an english build to confirm you see it there too.
(In reply to Jim Mathies [:jimm] from comment #12)
> This might also be language related. You might try spot checking an english
> build to confirm you see it there too.

I'm using a en-US Nightly build and the issue reproduces also on the non-localized facebook site.
I'll try to find the regression range.
(In reply to Jim Mathies [:jimm] from comment #11)
> (In reply to Mihaela Velimiroviciu [QA] (:mihaelav) from comment #10)
> > Created attachment 776323 [details]
> > screenshot
> > 
> > Now, it doesn't display the scrollbar in the input suggestions box at all
> > and the username (email address) is misaligned horizontally (extra space at
> > the begining and only the first letters are visible) 
> > See attached screenshot.
> > 
> > Do you want me to log a new issue for this or just reopen this one?
> 
> Some menu work landed recently, mind checking for a regression range? I'm
> using a build from mc tip yesterday morning and I don't see this at all.
> Either way, I lets file a follow up. Doesn't look related to the
> auto-complete menu change which landed 2013-07-03.

I logged the follow up bug 894396 and provided the requested info there.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130816030205
Built from http://hg.mozilla.org/mozilla-central/rev/1ed5a88cd4d0

WFM
Tested on windows 8 using latest nightly for iteration-12. I didn't see scroll-bar.
Status: RESOLVED → VERIFIED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.