Work - Extra space before the sugestion entries in the input suggestions pop-up

RESOLVED FIXED in Firefox 27

Status

P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mihaelav, Assigned: rsilveira)

Tracking

Trunk
Firefox 27
x86
Windows 8
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [preview] feature=work)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Mozilla/5.0 (Windows NT 6.2; rv:25.0) Gecko/20130715 Firefox/25.0

There is some blank space at the beginning of the suggestions in the input suggestions pop-up box.

Steps:
1. Go to facebook.com
2. Log in
3. Log out
4. Start typing again the same email address as in step 2

Expected result: Input suggestions pop-up box appears containing the email address from step 2. There is no extra blank space.

Actual result: There is some blank space before the email address.
See attached screenshot.

This is a regression since April the 8th:
Last good nightly: 2013-04-07
First bad nightly: 2013-04-08

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=be3be63607b0&tochange=b0d842380959

Updated

5 years ago
Blocks: 859003

Updated

5 years ago
Whiteboard: feature=defect c=tbd u=tbd p=0
There doesn't appear to be a screenshot attached? Could you attach it?

Updated

5 years ago
Flags: needinfo?(mihaela.velimiroviciu)
Priority: -- → P2

Comment 2

5 years ago
Created attachment 782192 [details]
fb-login-bug.jpg

Here's what I see on a standard DPI screen with today's nightly build on 8.0. It looks OK to me.

Comment 3

5 years ago
Because :mihaelav tracked down a regression window, leaving open until we hear back.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

5 years ago
Blocks: 855434
Whiteboard: feature=defect c=tbd u=tbd p=0 → feature=defect c=Content_features u=metro_firefox_user p=0

Updated

5 years ago
No longer blocks: 859003
Summary: Defect - Extra space before the sugestion entries in the input suggestions pop-up → Work - Extra space before the sugestion entries in the input suggestions pop-up
Whiteboard: feature=defect c=Content_features u=metro_firefox_user p=0 → feature=work
(Reporter)

Comment 4

5 years ago
Created attachment 785684 [details]
fb_login.jpg

This is how I see it in Metro mode on latest Nightly:  Mozilla/5.0 (Windows NT 6.2; rv:25.0) Gecko/20100101 Firefox/25.0, build ID 20130804030207
Flags: needinfo?(mihaela.velimiroviciu)

Updated

5 years ago
Blocks: 898833

Updated

5 years ago
Whiteboard: feature=work → feature=work [preview-triage]

Updated

5 years ago
Whiteboard: feature=work [preview-triage] → [Metro Preview] feature=work
Whiteboard: [Metro Preview] feature=work → [preview] feature=work
Left margin in the popup looks fine to me, but truncation/elipsis isn't happening and the result is the suggestions go right up to the right edge with no margin and are clipped. So there's still something wrong here. Its usable not pretty though and could use tightening up. 
p=2 at a guess though could turn out to be p=1

Updated

5 years ago
Priority: P2 → P3

Updated

5 years ago
Blocks: 918225
I think the patch in bug 918225 will fix the extra space before the menu entries (which shows up only when the "left hand" option is enabled in the Tablet PC Options control panel).
No longer blocks: 918225
Depends on: 918225
The extra space to the left should now be fixed by bug 918225.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Assignee: nobody → rsilveira
Target Milestone: --- → Firefox 27
You need to log in before you can comment on or make changes to this bug.