Remove Off-Main-Thread XPCWrappedJS refcounting from nsLDAPOperation

RESOLVED DUPLICATE of bug 882200

Status

defect
--
critical
RESOLVED DUPLICATE of bug 882200
6 years ago
6 years ago

People

(Reporter: opera.wang, Unassigned)

Tracking

({crash, regression})

Dependency tree / graph

Firefox Tracking Flags

(firefox23 unaffected, firefox24 affected)

Details

(crash signature)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

startup TB 24 Jun 11 nightly with my addon https://addons.mozilla.org/en-US/thunderbird/addon/ldapinfoshow/ installed
when my addon start to query LDAP using nsILDAPConnection/nsILDAPOperation/nsILDAPMessageListener
TB crashed

crash report:
https://crash-stats.mozilla.com/report/index/bp-0e72be8d-98ef-4212-82d4-7f3a42130612

It might related with bug 770840

So please set this bug block bug 773610



Actual results:

TB crashed


Expected results:

TB not crash
Blocks: 773610
This is likely the same as bug 882200.
Blocks: 770840
Severity: normal → critical
Status: UNCONFIRMED → NEW
Crash Signature: [@ nsXPCWrappedJS::AddRef() ]
Ever confirmed: true
Keywords: crash, regression
Version: Trunk → 24
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 882200
You need to log in before you can comment on or make changes to this bug.