Linux filepicker doesn't resize/compensate for long directory names

RESOLVED DUPLICATE of bug 88010

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 88010
17 years ago
13 years ago

People

(Reporter: djoham, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.1+) Gecko/20010625
BuildID:    2001062508

If you use the Mozilla/Linux filepicker and go deep enough into your directory
structure, you will eventually exceed the size that the filepicker can display
on its default height and width. The controls inside the picker then resize, but
the window does not. This renders the filepicker less useful, particularly if
you want to go up a directory. The user is forced to resize the picker himself.

This is also an issue if mozilla opens up the filepicker in a default directory
that exceeds the size of the window.

Reproducible: Always
Steps to Reproduce:
1. Make a couple of directories that have really long names
2. Navigate to those directories with the Linux Filepicker
3.

Actual Results:  The filepicker resizes its internal widgets, but not the window

Expected Results:  I would expect either the filepicker to change width
(sub-optimal) or somehow truncate the length of the directory displayed

I've attached a screenshot of what I'm talking about...

This is really a polish bug, nothing more...
This is only a problem with the modern theme (try classic!) and is due to
menulists in the modern theme not cropping.  Once bug 88010 is fixed this will
not be an issue.  Marking duplicate....

*** This bug has been marked as a duplicate of 88010 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.