Closed Bug 882342 Opened 7 years ago Closed 5 years ago

Crash in libstagefright_omx on Motorola XT890 running Android 4.1

Categories

(Core :: Audio/Video, defect, critical)

x86
Android
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX
mozilla25
Tracking Status
firefox21 --- unaffected
firefox22 --- affected
firefox23 --- affected
firefox24 --- fixed
firefox25 --- fixed

People

(Reporter: aaronmt, Assigned: eflores)

References

()

Details

(Keywords: crash, reproducible, Whiteboard: [native-crash][hold-off aurora uplift till we have status-firefox25])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-af9300f7-2717-4c98-b0c5-692492130612 .
============================================================= 

Device: Motorola XT890 (Razr I)
OS: Android 4.1
Build: Firefox Beta 22.0

I this this crash hitting play on http://vimeo.com/67913037
Version: 22 Branch → Trunk
Adding a close crash signature.
Crash Signature: [@ libstagefright_omx.so@0x1303b] → [@ libstagefright_omx.so@0x1303b] [@ libstagefright_omx.so@0x13055]
libstagefright_omx.so@0x1303b has been the topcrash for x86 on 22 Beta all the time. I think we might need to blocklist something there.
Keywords: topcrash
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #2)
> libstagefright_omx.so@0x1303b has been the topcrash for x86 on 22 Beta all
> the time.

This continues consistently with 23 Beta.
I'm thinking this should be blocklisted until we get a device we can test with.
Assignee: nobody → edwin
Is this the only device that needs to be blacklisted?
Flags: needinfo?(aaron.train)
Er, where "this" = Motorola XT890.
Will bug 860599's patch fix it?
Flags: needinfo?(chris.double)
(In reply to Scoobidiver from comment #7)
> Will bug 860599's patch fix it?

It doesn't look likely based on the stack frame but it would be great if someone could try it on the device to confirm.
Flags: needinfo?(chris.double)
Summary: crash in libstagefright_omx → Crash in libstagefright_omx on Motorola XT890 running Android 4.1
Attachment #778741 - Flags: review?(bjacob)
Flags: needinfo?(aaron.train)
Attachment #778741 - Flags: review?(bjacob) → review+
Kevin, you have an XT890 according to the wiki. Could you test that this blocklist patch works and if so, nominate for beta/aurora approval?
Flags: needinfo?(kbrosnan)
Kevin? Ping.
I am traveling and won't have access to the Razr I till the 13th of August. Aaron, Toronto has one, can you look at this?
Flags: needinfo?(kbrosnan) → needinfo?(aaron.train)
Confirming patch works for me on my XT890; used http://cd.pn/b

ro.product.model=XT890
ro.build.version.release=4.1.2
ro.build.version.sdk=16
Flags: needinfo?(aaron.train)
Comment on attachment 778741 [details] [diff] [review]
882342-blacklist-motorola-xt890-4.1.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Crash on video playback
Testing completed (on m-c, etc.): Tested blocklist patch on an XT890
Risk to taking this patch (and alternatives if risky): No risk, patch adds one other device to check for. Ask Edwin.
String or IDL/UUID changes made by this patch:
Attachment #778741 - Flags: approval-mozilla-beta?
Attachment #778741 - Flags: approval-mozilla-aurora?
Attachment #778741 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Is this needed on 25?
Flags: needinfo?(kairo)
Whiteboard: [native-crash] → [native-crash][hold-off aurora uplift till we have status-firefox25]
Comment on attachment 778741 [details] [diff] [review]
882342-blacklist-motorola-xt890-4.1.patch

This should uplift for FF24 on Aurora in order to be on Beta when it merges on Monday but since we're not shipping x86 builds for FF23, we don't need to respin our final beta/RC of FF23 for this.
Attachment #778741 - Flags: approval-mozilla-beta? → approval-mozilla-beta-
(In reply to Aaron Train [:aaronmt] from comment #16)
> Is this needed on 25?

I'm pretty sure 25 has the same crashes, but I would guess if we need it there depends on bug 860599 landing in this train or not. If it does, we probably should not blocklist there and see if this one is fixed as well by that mechanism. If that doesn't land, we'll need to block on the 25 train as well.
Flags: needinfo?(kairo)
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #18)
> (In reply to Aaron Train [:aaronmt] from comment #16)
> > Is this needed on 25?
> 
> I'm pretty sure 25 has the same crashes, but I would guess if we need it
> there depends on bug 860599 landing in this train or not. If it does, we
> probably should not blocklist there and see if this one is fixed as well by
> that mechanism. If that doesn't land, we'll need to block on the 25 train as
> well.

Just spun up an x86 build with the patch from bug 860599, and it still crashes with that; so will have to land this on 25.
https://hg.mozilla.org/mozilla-central/rev/6e7d9cb27760
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
I've updated https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_Android_2 accordingly. It should have been done by the assignee.
This has been blacklisted. Leave it open for an actual fix.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
no longer a topcrash
Keywords: topcrash
Stagefright no longer used on 4.1.x after bug 1014614.
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.