If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

CorrelationsSignatures should not raise NotFoundError

RESOLVED FIXED in 51

Status

Socorro
Backend
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: peterbe, Assigned: peterbe)

Tracking

unspecified
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

4 years ago
On URLs like
/bpapi/correlations/signatures/report_type/core-counts/product/Firefox/version/23.0a1/platforms/Mac%20OS%20X/

It might raise an error simply because it can't find that appropriate .txt (or .txt.gz) file but instead it should just return null.
(Assignee)

Comment 1

4 years ago
PR: https://github.com/mozilla/socorro/pull/1296

Comment 2

4 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/36af048fc1018d44aa8a92ce6a27f68afa2f82a2
fixes bug 882489 - CorrelationsSignatures should not raise NotFoundError, r=rhelmer

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Blocks: 749359
Assignee: nobody → peterbe
Target Milestone: --- → 51
Duplicate of this bug: 885781
You need to log in before you can comment on or make changes to this bug.