Closed Bug 882652 Opened 7 years ago Closed 7 years ago

After a restart the SocialAPI sidebar is displayed in popups that didn't show it before

Categories

(Firefox Graveyard :: SocialAPI, defect)

x86
macOS
defect
Not set

Tracking

(firefox21 wontfix, firefox22- wontfix, firefox23+ verified, firefox24 verified)

VERIFIED FIXED
Firefox 24
Tracking Status
firefox21 --- wontfix
firefox22 - wontfix
firefox23 + verified
firefox24 --- verified

People

(Reporter: florian, Assigned: mixedpuppy)

References

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:
1. Have a SocialAPI sidebar visible.
2. Use a site that opens a popup (eg go to https://air.mozilla.org/ and click the "sign in" Persona button).
3. Without closing the Persona popup, restart Firefox (eg by disabling/enabling a non-bootstrapped add-on).

Expected result: After restarting, the windows are in the same state as before.

Actual result: A SocialAPI sidebar is shown in the Persona popup.
Can you please provide more information for steps 2 and 3.
Are you restarting Firefox after disabling add-on and again after enabling add-on?
Also, can you please attach image of your actual result?
Flags: needinfo?(florian)
This doesn't have anything to do with addons, ignore that part of step 3.  IMO step 2 is clear enough.

There was a bug on this, and it has to do with session restore not restoring a window attribute (I think extrachrome=no or something like that).  I was unable to locate that bug again.

On a separate note, I wonder if the persona window should be reopened, probably not.
Yeah, we've tracked down steps to reproduce and are working on a regression range right now. It seems this does not reproduce in Firefox 17 so there's a regression somewhere.

Regarding session restore and persona, I agree that we probably want to blacklist Persona windows from Session Restore since it restores in an unusable state. But that's a different bug I think.
here it is, bug 779054 was a fix for fx17, not surprised that is regressed since lots has changed since then.  The real culprit at the time is discussed in bug 779729.  I'm assuming that is still the primary cause, but we can probably fix it at least for social.
Flags: needinfo?(florian)
Shane, do you still need a regression window?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #5)
> Shane, do you still need a regression window?

I don't think it is necessary, might be nice to know if it also affects fx23, I haven't checked.
It can be reproduced on FX20,FX21,FX22b5,FX23 latest Aurora and can not be reproduced on FX17, FX18, FX19.

FX23:
User Agent: Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130613 Firefox/23.0
Build ID: 20130613004019

FX22b5:
User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0
Build ID:20130612084701

FX21:
User Agent:Mozilla/5.0 (X11; Linux i686; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID:20130511120803

FX20:
User Agent:Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID:20130326150557

Steps to reproduce:
1. Start with a new profile
2. Go to fb.com/about/messenger-for-firefox
3. Click Turn On
4. Go to moztrap.mozilla.org and click Sign In
5. A persona window will pop up, switch to the main Firefox window
6. Click File and then Quit
7. Start Firefox
8. Go to about:home and click Restore Previous Session

Expected Result:
Persona window will restore without a Social Sidebar

Actual result:
Persona window will restore with a Social Sidebar
I think we should fix this in Aurora, at least.
should be a quick fix, I'll get to it this afternoon.
Assignee: nobody → mixedpuppy
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #9)
> I think we should fix this in Aurora, at least.

Final beta now, so we're extra stingy on changes. Agreed on getting this into 23.
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 808215
User impact if declined: social sidebar may appear in popup windows (when it shouldnt) after session restore
Testing completed (on m-c, etc.): manual on m-c
Risk to taking this patch (and alternatives if risky): patch is trivial, low risk
String or IDL/UUID changes made by this patch: none

I realize I'm requesting this at the same time as review, but it really is a trivial patch, and the timeframe for aurora is short.
Attachment #762886 - Flags: review?(gavin.sharp)
Attachment #762886 - Flags: approval-mozilla-aurora?
Comment on attachment 762886 [details] [diff] [review]
fix disabling social in popups opened from session restore

Why are you leaving the check for extrachrome, as opposed to the previous fix that replaced it?
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #13)
> Comment on attachment 762886 [details] [diff] [review]
> fix disabling social in popups opened from session restore
> 
> Why are you leaving the check for extrachrome, as opposed to the previous
> fix that replaced it?

In removed code in the patch from bug 808215, extrachrome was checked for most ui elements, except the sidebar.  While manual testing shows that only checking toolbar should be fine, I'm unsure if that is true in all cases.  Checking for both seemed to be the safer route.
Attachment #762886 - Flags: review?(gavin.sharp) → review+
https://hg.mozilla.org/mozilla-central/rev/6e2ad7bd617e
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 24
Attachment #762886 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Samvedana, please verify this is fixed in Firefox 23 and 24.
Keywords: verifyme
QA Contact: samvedana.gohil
User Agent : Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
Build ID : 20130708202947

Tested on Firefox 23-B4 using steps provided in Comment-7, I am getting expected result.

Persona window restores without a Social Sidebar
Status: RESOLVED → VERIFIED
User Agent : Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20130711 Firefox/25.0
Build ID:20130711030204

Tested on latest nightly using steps provided in Comment-7, I am getting expected result.
Persona window restores without a Social Sidebar

User Agent : Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20130711 Firefox/24.0
Build ID : 20130711004005

Tested on latest Aurora using steps provided in Comment-7, I am getting expected result.
Persona window restores without a Social Sidebar
Status: VERIFIED → RESOLVED
Closed: 7 years ago7 years ago
Marking this verified based on comment 20, thanks Samvedana.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.