Closed Bug 883014 Opened 8 years ago Closed 7 years ago

Session store _collectTabData assumes about:blank has a document.body

Categories

(Firefox :: Session Restore, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 973550

People

(Reporter: jruderman, Unassigned)

Details

(Keywords: testcase)

Attachments

(1 file)

Attached file testcase
1. Set:
     user_pref("media.webm.enabled", false);
2. Load the testcase
3. Click the button
4. Watch the Browser Console (or stdout / stderr in a debug build)

Result:

[Exception... "'[JavaScript Error: "browser.contentDocument.body is null" {file: "resource:///modules/sessionstore/SessionStore.jsm" line: 1910}]' when calling method: [nsIObserver::observe]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: yes]

>    else if (browser.currentURI.spec != "about:blank" ||
>             browser.contentDocument.body.hasChildNodes()) {
I can't reproduce the error in my trunk build. Is it still reproducible for you?
Yes, I can still reproduce with https://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-central-macosx64-debug/1373658654/ built from http://hg.mozilla.org/mozilla-central/rev/3433a021847b

Sometimes I have to wait a second or two for the exception.  Setting a second pref seems to help:

  user_pref("media.webm.enabled", false);
  user_pref("browser.sessionstore.resume_from_crash", false);
Now I get:

System JS : ERROR resource://app/modules/sessionstore/SessionHistory.jsm:121 - TypeError: webNavigation.document.body is null

(a different error in a different file)

Maybe this morphed into bug 973550?
Indeed it did. Let's fix it there.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 973550
You need to log in before you can comment on or make changes to this bug.