Closed Bug 883172 Opened 8 years ago Closed 8 years ago

[socorro-crashstats] Reports table in reports/list has too few reports listed

Categories

(Socorro :: Webapp, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kairo, Assigned: jezdez)

References

Details

Compare the "Reports" tabs of https://crash-stats-django.mozilla.org/report/list?signature=nsXPCWrappedJS%3A%3AAddRef%28%29 and https://crash-stats.mozilla.com/report/list?signature=nsXPCWrappedJS%3A%3AAddRef%28%29 - the socorro-crashstats one misses a lot of the reports listed in the PHP table.
Blocks: 749359
Think the problem is in forms.py:L113
        return self.cleaned_data['product'] or [settings.DEFAULT_PRODUCT]
when the product is not supplied in the URL, it's defaulting to Firefox. (Note the header on the link above says "Results within 7 days of 2013-06-14, and the product is Firefox..."
Assignee: nobody → jezdez
Status: NEW → ASSIGNED
Commits pushed to master at https://github.com/mozilla/socorro-crashstats

https://github.com/mozilla/socorro-crashstats/commit/74fe1c8a303347407509ef70e3249880ee0cee20
bug 883172 - stop using the default product for the report list.

https://github.com/mozilla/socorro-crashstats/commit/be13389aa20b90fa646210d7cb848b09787a5bd8
Merge pull request #386 from rhelmer/bug883172-broken-report-list

bug 883172 - stop using the default product for the report list.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Thanks Robert!
You need to log in before you can comment on or make changes to this bug.