crash in nsDNSAsyncRequest::OnLookupComplete @ nsXPCWrappedJS::CallMethod

RESOLVED FIXED in Firefox 24

Status

()

defect
--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: scoobidiver, Assigned: jdm)

Tracking

({crash, regression})

24 Branch
mozilla24
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox23 unaffected, firefox24 verified)

Details

(crash signature)

Attachments

(1 attachment)

With the stack trace below, it first showed up in 24.0a1/20130612. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=86413e921d5d&tochange=0414d6d0f60d
It's likely a regression from bug 770840.

Signature 	nsXPCWrappedJS::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*) More Reports Search
UUID	d18042d9-37ed-40e8-94bc-090482130614
Date Processed	2013-06-14 14:10:48
Uptime	24
Last Crash	1.1 hours before submission
Install Age	24 seconds since version was first installed.
Install Time	2013-06-14 14:10:27
Product	Firefox
Version	24.0a1
Build ID	20130614031100
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	AuthenticAMD family 15 model 107 stepping 2
Crash Reason	EXCEPTION_BREAKPOINT
Crash Address	0x611205cf
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x689e, AdapterSubsysID: 00000000, AdapterDriverVersion: 9.2.0.0
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
Processor Notes 	sp-processor01_phx1_mozilla_com_25518:2012
EMCheckCompatibility	True
Adapter Vendor ID	0x1002
Adapter Device ID	0x689e
Total Virtual Memory	2147352576
Available Virtual Memory	1656975360
System Memory Use Percentage	61
Available Page File	2796986368
Available Physical Memory	836923392

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/xpconnect/src/XPCWrappedJS.cpp:571
1 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:85
2 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:112
3 	xul.dll 	nsDNSAsyncRequest::OnLookupComplete 	netwerk/dns/nsDNSService2.cpp:294

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsXPCWrappedJS%3A%3ACallMethod%28unsigned+short%2C+XPTMethodDescriptor+const*%2C+nsXPTCMiniVariant*%29
Crash Signature: [@ nsXPCWrappedJS::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*)] → [@ nsXPCWrappedJS::CallMethod(unsigned short, XPTMethodDescriptor const*, nsXPTCMiniVariant*) ]
nsDNSAsyncRequest::mListener can be scripted and nsDNSAsyncRequest::OnLookupComplete can be called on a background thread.
Assignee: nobody → josh
Attachment #763221 - Flags: review?(mcmanus) → review+
Keywords: checkin-needed
Target Milestone: --- → mozilla24
Interesting that it didn't leak on Try - did you push the wrong version of it to inbound? Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/3a85eb8af304 for the same leak as before.
Third time's the charm (I did, in fact, push the wrong version last time): https://hg.mozilla.org/integration/mozilla-inbound/rev/1c1ae670a995
https://hg.mozilla.org/mozilla-central/rev/1c1ae670a995
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
There are still crashes after the fix.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I'm going to clone this and track the failure there.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Blocks: 887191
Verified as fixed, since there are very few (5-6) crashes in this last month regarding 24.0b5, 25.0a2, 26.0a1.

Details here:

https://crash-stats.mozilla.com/report/list?signature=nsXPCWrappedJS%3A%3ACallMethod%28unsigned+short%2C+XPTMethodDescriptor+const*%2C+nsXPTCMiniVariant*%29
QA Contact: manuela.muntean
You need to log in before you can comment on or make changes to this bug.