Error creating Disk Space Watcher

RESOLVED DUPLICATE of bug 895964

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 895964
4 years ago
4 years ago

People

(Reporter: Mitra Ardron, Unassigned)

Tracking

23 Branch
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gs], URL)

(Reporter)

Description

4 years ago
I'm seeing this error in the Error Console at startup.

While creating services from category 'profile-after-change', could not create service for entry 'Disk Space Watcher Service', contract ID '@mozilla.org/toolkit/disk-space-watcher;1'

Evernote is behaving very poorly, I don't know if this error is related to that problem, but I've been asked enough times to create one bug report per problem. :-(

https://bugzilla.mozilla.org/show_bug.cgi?id=868041
(Reporter)

Comment 1

4 years ago
The real bug I'm trying to track down is Bug #868041 and I'm also seeing Bug #883622 which may or may not be related

Updated

4 years ago
Depends on: 868041, 883622

Comment 2

4 years ago
I do see it too on Win XP, TB 24 trunk.

The message may come from here:
http://mxr.mozilla.org/comm-central/source/mozilla/xpcom/components/nsCategoryManager.cpp#831

In hg log, there are no recent changes in that file.
FYI. 
Same error is reported for Fx 24. Bug 865348(Win7), Bug 876850(Android)
(Reporter)

Comment 4

4 years ago
The interesting thing is that the error has stopped appearing for me, AND Bug #868041 has stopped happening, this may suggest that there is some relationship e.g. that the failure that generates this error also does something that a few minutes later stops TB moving files between folders (without generating any error messages despute the failure :-(

Updated

4 years ago

Comment 5

4 years ago
(In reply to :aceman from comment #2)
> I do see it too on Win XP, TB 24 trunk.
> 
> The message may come from here:
> http://mxr.mozilla.org/comm-central/source/mozilla/xpcom/components/
> nsCategoryManager.cpp#831
> 
> In hg log, there are no recent changes in that file.

What do you make of it?  HOw to reproduce?  Can it cause performance issues?
Flags: needinfo?(acelists)

Comment 6

4 years ago
I still do see it, just by starting TB trunk on Win XP.
From the name of the component, I guess it may just send some events when the disk space is getting low. I have no idea if we use that in any way in TB.
Flags: needinfo?(acelists)

Comment 7

4 years ago
(In reply to :aceman from comment #6)
> I still do see it, just by starting TB trunk on Win XP.
> From the name of the component, I guess it may just send some events when
> the disk space is getting low. I have no idea if we use that in any way in
> TB.

I see this too under linux (32-bit, 64-bit Debian GNU/Linux) when I run |make mozmill| test suite of locally build TB.  Strange, I only began seeing this after this summer (around the beginning of October when I refreshed my local copy of comm-central.)

The error is recorded in the built-in Error Console of TB as follows (as the first item in it):

While creating services from category 'profile-after-change', could
not create service for entry 'Disk Space Watcher Service', contract ID
'@mozilla.org/toolkit/disk-space-watcher;1'


Since the beginning of October, I got the line warning near the start of the |make mozmill| tesst sute.


WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 298


Looking at the surrounding context, I think the call to
create this service is made too early, I think.

--- begin quote of log:
  [...]
INFO | (runtestlist.py) | Running directory: addrbook
['/REF-OBJ-DIR/objdir-tb3/./mozilla/_tests/mozmill/../mozmill-virtualenv/bin/python', 'runtest.py', '-t', '/REF-COMM-CENTRAL/comm-central/mail/test/mozmill/addrbook', '--binary', '../../.././mozilla/dist/bin/thunderbird', '--symbols-path', '/REF-OBJ-DIR/objdir-tb3/./mozilla/dist/crashreporter-symbols', '--plugins-path', '/REF-OBJ-DIR/objdir-tb3/./mozilla/dist/plugins']
Calling mallopt for malloc/free debug. with 0xc3 value.
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 298
1380555870823	Marionette	INFO	MarionetteComponent loaded
++DOCSHELL 0x2c117f0 == 1 [id = 1]
++DOMWINDOW == 1 (0x2c15438) [serial = 1] [outer = (nil)]
 [...]
--- end quote of log

You can see that the warning appears immediately after TB binary is invoked before other messages appear.
Also, the recording of the error in Error Console appears as the first item in the recording.

Calling the relevant function to create the service BEFORE the infrastructure (subsystem under a proper thread, etc.) is ready seems to be the culprit IMHO.

Comment 8

4 years ago
Mitra, are you seeing slowness associated with this error
Flags: needinfo?(mitra_lists)
(Reporter)

Comment 9

4 years ago
I'm not seeing the error any more Wayne. I've updated my machine to one with a lot more disk space, but the error went away previously (in June) as mentioned in Comment #4
Flags: needinfo?(mitra_lists)

Comment 10

4 years ago
Still appearing here on OS X 10.9 trunk build just pulled. Also I think error started to show from October, but I haven't been pulling repo very often. Maybe error started showing before October.

I don't build with tests enabled, so I am not able to see any mozmill error, Ishikawa-san.

Comment 11

4 years ago
(In reply to Javi Rueda from comment #10)
> Still appearing here on OS X 10.9 trunk build just pulled. Also I think
> error started to show from October, but I haven't been pulling repo very
> often. Maybe error started showing before October.
> 
> I don't build with tests enabled, so I am not able to see any mozmill error,
> Ishikawa-san.

Well, mozmill suggests that the disk file status is not available when the 
program tries to obtain disk status, presumably remaining empty space, etc.
That sounds bad.

Note |nsIDiskSpaceWatcher| and IndexedDataBaseManager.cpp file name below.
 
Running egrep -i watch lofile-from-mozmill-run, and
removed unrelated lines:

WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: Could not get disk status from nsIDiskSpaceWatcher: file /REF-COMM-CENTRAL/comm-central/mozilla/uriloader/prefetch/nsOfflineCacheUpdateService.cpp, line 312
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: Could not get disk status from nsIDiskSpaceWatcher: file /REF-COMM-CENTRAL/comm-central/mozilla/uriloader/prefetch/nsOfflineCacheUpdateService.cpp, line 312
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: Could not get disk status from nsIDiskSpaceWatcher: file /REF-COMM-CENTRAL/comm-central/mozilla/uriloader/prefetch/nsOfflineCacheUpdateService.cpp, line 312
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: Could not get disk status from nsIDiskSpaceWatcher: file /REF-COMM-CENTRAL/comm-central/mozilla/uriloader/prefetch/nsOfflineCacheUpdateService.cpp, line 312
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: Could not get disk status from nsIDiskSpaceWatcher: file /REF-COMM-CENTRAL/comm-central/mozilla/uriloader/prefetch/nsOfflineCacheUpdateService.cpp, line 312
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: No disk space watcher component available!: file /REF-COMM-CENTRAL/comm-central/mozilla/dom/indexedDB/IndexedDatabaseManager.cpp, line 301
WARNING: Could not get disk status from nsIDiskSpaceWatcher: file /REF-COMM-CENTRAL/comm-central/mozilla/uriloader/prefetch/nsOfflineCacheUpdateService.cpp, line 312


So this could mean some optimization such as prefetch, or database feature is running without being able
to tell if there is enough space available in the disk? Someone in the know can answer this?

Comment 12

4 years ago
the disk watcher error msg is bug 895964 and so likely be ignored and this is a dupe
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 895964
(Reporter)

Comment 13

4 years ago
Probably should have done the Dupe the other way around given the comment train here, and that bug #895964 was reported at a later date.

Updated

4 years ago
Depends on: 895964
You need to log in before you can comment on or make changes to this bug.