[Cost Control]In Usage Graph Wi-Fi Toggle is always unchecked after closing the Usage app and again Reopen

RESOLVED FIXED in Firefox OS v1.1hd

Status

P2
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: leo.bugzilla.gaia, Assigned: johnhu)

Tracking

unspecified
1.1 QE3 (26jun)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

Details

(Whiteboard: [TD-45859])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
1. Title : In Usage Graph Wi-Fi Toggle is always unchecked after closing the Usage app and again Reopen.
2. Precondition : Usage->Wi-Fi Toggle ON
3. Tester's Action : Close the Usage app and again reopen it.
4. Detailed Symptom (ENG.) :when data graph is FIRST SEEN after setup flow: Wifi usage toggle should be OFF and once the user checked the wi-fi toggle it should  maintain it state even after closing the Usage app.But it is always unchecked.
6.Reproducibility: Y
1)Frequency Rate : 100%\
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 0c836be7f24693b74ad7fd21c8153824f1c7f548
9.Personal email id: vsireesha246@gmail.com
(Reporter)

Updated

5 years ago
blocking-b2g: --- → leo+
Whiteboard: [TD-45859]
Target Milestone: --- → 1.1 QE3 (24jun)
(Reporter)

Updated

5 years ago
OS: Windows XP → Gonk (Firefox OS)
Hardware: x86 → ARM
(Reporter)

Updated

5 years ago
Priority: -- → P2
Assignee: nobody → johu
Created attachment 763466 [details]
patch for this bug

use asyncStorage to save the state of user's choice.
Attachment #763466 - Flags: review?(salva)
Comment on attachment 763466 [details]
patch for this bug

Check comments on GitHub, please.
Attachment #763466 - Flags: review?(salva) → review-
Comment on attachment 763466 [details]
patch for this bug

Sorry, I am a stupid guy. The console.log line should be removed. I missed that.

I had changed the code according to comments, ran gjslint, and ran unit tests. Please review it again. Thanks.
Attachment #763466 - Flags: review- → review?(salva)
Comment on attachment 763466 [details]
patch for this bug

Not stupid at all. Thank you very much for the quick fix. Please, review the latest nit before merge and ping me when done.
Attachment #763466 - Flags: review?(salva) → review+
Salvador, 

I had fixed the code according to your comment. Please see it before I merge it.
It seems ok, good work. Let's close this.
Master: 016a92d86d3b9afb264ea350ad93ef8e687cf7b0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Uplifted 016a92d86d3b9afb264ea350ad93ef8e687cf7b0 to:
v1-train: 82f1f0ad49f529f336266493b7a8944584485242
status-b2g18: --- → fixed
1.1hd: 82f1f0ad49f529f336266493b7a8944584485242
status-b2g-v1.1hd: --- → fixed
Duplicate of this bug: 813066
You need to log in before you can comment on or make changes to this bug.