Closed Bug 883822 Opened 6 years ago Closed 6 years ago

[SMS] The handset keeps displaying the keyboard even when back button on the Compose screen is clicked

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect, P2, minor)

ARM
Gonk (Firefox OS)

Tracking

(blocking-b2g:leo+, b2g18 fixed, b2g-v1.1hd fixed)

VERIFIED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed
b2g-v1.1hd --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: kaze)

References

Details

(Whiteboard: [TD-44992][u=commsapps-user c=messaging p=1], [LeoVB+])

Attachments

(2 files)

1. Title:  The handset keeps displaying the keyboard even when back button  Compose screen is clicked
2. Precondition: One contact on Call Logs and Contact should be saved in contact app
3. Tester's Action:(1) Dial->Call Logs->Select a call log->Press the message icon
                   (2) Do not tip any letter on keyboard > Back
                   (3) Check the screen.
4. Detailed Symptom (ENG.) : The handset keeps displaying the keyboard on the screen.
5. Expected: The handset should not display the keyboard on the screen anymore.
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train: Reproduced on v1-train and master
8. Gaia Revision:  20c8fb29caf13e5a4530ba5c7b837a849c79c91b
9. Personal email id: sasikala.paruchuri8@gmail.com
blocking-b2g: --- → leo+
Whiteboard: [TD-44992]
Target Milestone: --- → 1.1 QE3 (24jun)
Assignee: nobody → anthony
Priority: -- → P2
Attached image Screenshot attached
Please find the screenshot attached for this issue
Precondition:
- At least 1 contact with phone number
- Message app is not launched

STR:
1. Open contact app
2. Tap on contact with phone number
3. Tap "send message" icon on the right side of the phone number
4. Automatically transit to message app
5. Press back button
Anthony, are you working on this?
Flags: needinfo?(anthony)
I reproduced it earlier this week but can't reproduce anymore. I believe this was fixed by bug 878735. And this was uplifted to v1-train.

Feel free to re-open if you're still seeing this with a build containing the patch from bug 87835.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(anthony)
Resolution: --- → FIXED
I also think bug 878735 will solve it, the root cause was the focus.
now in bug 878735 patch we are explicitly requesting focus to recipient list.
There doesn't seem to be any resolving code here o_O
Resolution: FIXED → WORKSFORME
This is still happening as described on comment 2 and shown on the attachment. Reopening

Unagi v1-train build:
Gecko-96c693c
Gaia-0d5a9a7
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Unassigning myself as I'll be on PTO starting tomorrow.
Assignee: anthony → nobody
Assignee: nobody → felash
Whiteboard: [TD-44992] → [TD-44992][u=commsapps-user c=contacts p=1]
Whiteboard: [TD-44992][u=commsapps-user c=contacts p=1] → [TD-44992][u=commsapps-user c=dialer
Whiteboard: [TD-44992][u=commsapps-user c=dialer → [TD-44992][u=commsapps-user c=dialer p=1]
Whiteboard: [TD-44992][u=commsapps-user c=dialer p=1] → [TD-44992][u=commsapps-user c=messaging p=1]
The patch works well on leo
Isabel, could you please to reproduce this again ?
Hi Julien,

Yes, I see it with 07/07 v1-train build: 
Gecko-e7708d4
Gaia-d336288
Julien, please email us if you don't believe this will hit the 7/15 date.
Flags: needinfo?(felash)
Target Milestone: 1.1 QE3 (26jun) → 1.1 QE4 (15jul)
giving this to kaze who has some free cycles
Assignee: felash → kaze
Flags: needinfo?(felash)
Comment on attachment 775663 [details]
link to pull request

Code looks good, just waiting for a clean pass in the unit suite - Please request review again after update!  Thanks!
Attachment #775663 - Flags: review?(gnarf37) → review-
Comment on attachment 775663 [details]
link to pull request

All fixed - Units are good - r=me
Attachment #775663 - Flags: review- → review+
v1.1.0hd: 773a197b4e18377f366a0815778789aa4f25d412
v1.1.0hd: d17ada15640c4e926693a7f43110ca1e5577c73d
Cannot reproduce this issue with latest unagi v1-train build:
Gecko-f94f793
Gaia-ef03c2b
ref ril

Verified.
Status: RESOLVED → VERIFIED
Bug 878735 will solve this issue, the root cause was the focus.
now in bug 878735 patch we are explicitly requesting focus to recipient list.

So we have not taken this patch because 878735 already solved the issue.
Leo, see comment 11: strangely, this does not seem to be fixed by the fix in bug 878735 ?
Hi Julien,
But the issue is not reproducible after applying the patch.

(In reply to Julien Wajsberg [:julienw] (PTO 15th -> 28th July) from comment #22)
> Leo, see comment 11: strangely, this does not seem to be fixed by the fix in
> bug 878735 ?
I think you should not diverge from our v1-train branch, this will make bug solving harder...
Hi Julienw,

We have tested and took the patch.

Thanks,
Whiteboard: [TD-44992][u=commsapps-user c=messaging p=1] → [TD-44992][u=commsapps-user c=messaging p=1], [LeoVB+]
You need to log in before you can comment on or make changes to this bug.