Closed Bug 883844 Opened 9 years ago Closed 9 years ago

AudioBufferSourceNodes scheduled in a sequence aren't seamless

Categories

(Core :: Web Audio, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 913854

People

(Reporter: roc, Assigned: padenot)

References

Details

(Whiteboard: [blocking-webaudio-])

Assignee: nobody → paul
Weird. I've played a lot with sample accurate scheduling for musical applications and I have not observed such behavior, the playback was sample accurate all the time.

I'll have a look.
Blocks: 886381
Whiteboard: [blocking-webaudio-]
The testcase in bug 913854 plays back fine with large enough buffering, so I suspect the issues here with 48kHz are just from not enough buffering.
(I didn't work out what SDL.audio.samples was set to here.)
For the other sample rates, duping to bug 913854, which links to another testcase, sharing much of this code, but with controls to tune the buffering.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 913854
You need to log in before you can comment on or make changes to this bug.