Last Comment Bug 884279 - renaming future to promise
: renaming future to promise
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86_64 Linux
: -- normal with 1 vote (vote)
: mozilla25
Assigned To: Andrea Marchesini [:baku]
:
Mentors:
Depends on: 885318
Blocks: 885333
  Show dependency treegraph
 
Reported: 2013-06-18 05:44 PDT by Andrea Marchesini [:baku]
Modified: 2013-07-12 14:42 PDT (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (70.78 KB, patch)
2013-06-18 05:45 PDT, Andrea Marchesini [:baku]
mounir: review+
Details | Diff | Splinter Review
patch (70.10 KB, patch)
2013-06-19 01:29 PDT, Andrea Marchesini [:baku]
no flags Details | Diff | Splinter Review
patch for m-i (70.16 KB, patch)
2013-06-19 15:03 PDT, Andrea Marchesini [:baku]
no flags Details | Diff | Splinter Review
patch (70.16 KB, patch)
2013-06-20 01:35 PDT, Andrea Marchesini [:baku]
no flags Details | Diff | Splinter Review
patch (72.44 KB, patch)
2013-06-26 05:07 PDT, Andrea Marchesini [:baku]
no flags Details | Diff | Splinter Review
patch (72.50 KB, patch)
2013-07-11 11:41 PDT, Andrea Marchesini [:baku]
no flags Details | Diff | Splinter Review

Description Andrea Marchesini [:baku] 2013-06-18 05:44:02 PDT
Splitting bug 875289
Comment 1 Andrea Marchesini [:baku] 2013-06-18 05:45:37 PDT
Created attachment 764103 [details] [diff] [review]
patch
Comment 2 Mounir Lamouri (:mounir) 2013-06-18 15:18:32 PDT
Comment on attachment 764103 [details] [diff] [review]
patch

Review of attachment 764103 [details] [diff] [review]:
-----------------------------------------------------------------

Please use `hg mv` for Future.webidl -> Promise.webidl.

::: modules/libpref/src/init/all.js
@@ +1821,5 @@
>  
>  // If true, ArchiveReader will be enabled
>  pref("dom.archivereader.enabled", false);
>  
>  // If true, Future will be enabled

s/Future/Promise/
Comment 3 Andrea Marchesini [:baku] 2013-06-19 01:29:43 PDT
Created attachment 764622 [details] [diff] [review]
patch
Comment 4 :Ehsan Akhgari 2013-06-19 11:00:36 PDT
This doesn't apply cleanly on inbound since Promise.h does not exist there.
Comment 5 Andrea Marchesini [:baku] 2013-06-19 14:57:14 PDT
?!? Promise.h is a renaming of Future.h it's included in this patch.
Comment 6 Andrea Marchesini [:baku] 2013-06-19 15:03:18 PDT
Created attachment 765025 [details] [diff] [review]
patch for m-i
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-06-19 18:01:08 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/c1596bee956c
Comment 8 :Ehsan Akhgari 2013-06-19 18:59:56 PDT
Backed out because of build bustage: https://hg.mozilla.org/integration/mozilla-inbound/rev/6208332c8b04
Comment 10 Andrea Marchesini [:baku] 2013-06-20 01:35:12 PDT
Created attachment 765243 [details] [diff] [review]
patch

Rebased on top of m-c and m-i
Comment 11 Andrea Marchesini [:baku] 2013-06-20 01:52:29 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/96036434bb78
Comment 12 Andrea Marchesini [:baku] 2013-06-20 06:43:29 PDT
Backed out becuause of 885318

remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/2266ccdba6d7
remote:   https://hg.mozilla.org/integration/mozilla-inbound/rev/bf5031737e46
Comment 13 Ryan VanderMeulen [:RyanVM] 2013-06-20 16:35:11 PDT
BTW, this patch has bug 875289 in the commit message. I fixed it when I pushed it the first time, but you need to fix it in your local queue before you push it again.
Comment 14 Andrea Marchesini [:baku] 2013-06-26 05:07:43 PDT
Created attachment 767707 [details] [diff] [review]
patch

rebased
Comment 15 Andrea Marchesini [:baku] 2013-07-11 11:41:18 PDT
Created attachment 774146 [details] [diff] [review]
patch

Rebased

https://tbpl.mozilla.org/?tree=Try&rev=4e48e1903f13
Comment 16 Ryan VanderMeulen [:RyanVM] 2013-07-11 13:47:06 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/cc1d6a5a4840
Comment 17 Ryan VanderMeulen [:RyanVM] 2013-07-12 10:59:01 PDT
https://hg.mozilla.org/mozilla-central/rev/cc1d6a5a4840

Note You need to log in before you can comment on or make changes to this bug.