Closed Bug 884291 Opened 6 years ago Closed 6 years ago

Localized Lightning *nightly* builds using Thunderbird Infrastructure

Categories

(Calendar :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Fallen, Assigned: Fallen)

References

Details

Attachments

(1 file, 1 obsolete file)

In bug 855067 I mostly took care of the beta and release builds. I initially had it working for nightly builds too, but it seems this broke inbetween. This bug is to find out why.
OS: Mac OS X → All
Hardware: x86 → All
Looks like I missed transplanting one changeset from c-b (7145009f2017), doing this now:

https://hg.mozilla.org/releases/comm-aurora/rev/b70c6ab4ac85
https://hg.mozilla.org/comm-central/rev/2da3d838b23f

Leaving the bug open until it works.
Only win32 is still failing. There are a lot of these:

> Error executing command awk [Error 2] The system cannot find the file specified

which I assume go back to path issues with the call to get the locales from the shipped-locales file. Then there is this:

e:\builds\moz2_slave\tb-c-aurora-w32-l10n-ntly-0000\build\comm-aurora\calendar\lightning\lightning-packager.mk:161:0: command 'echo "[Build]" >> e:/builds/moz2_slave/tb-c-aurora-w32-l10n-ntly-0000/build/comm-aurora/objdir-tb/mozilla/dist/bin/platform.ini' failed, return code 1

...


e:\builds\moz2_slave\tb-c-aurora-w32-l10n-ntly-0000\build\comm-aurora\objdir-tb\mail\locales\Makefile:218:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/tb-c-aurora-w32-l10n-ntly-0000/build/comm-aurora/mozilla/build/pymake/pymake/../make.py -C ../../calendar/lightning langpack-de' failed, return code 2
/usr/bin/sh: e:/builds/moz2_slave/tb-c-aurora-w32-l10n-ntly-0000/build/comm-aurora/objdir-tb/mozilla/dist/bin/platform.ini: No such file or directory
Traceback (most recent call last):
  File "e:/builds/moz2_slave/tb-c-aurora-w32-l10n-ntly-0000/build/comm-aurora/build/pymake/make.py", line 35, in <module>
    main(sys.argv[1:])
  File "e:/builds/moz2_slave/tb-c-aurora-w32-l10n-ntly-0000/build/comm-aurora/build/pymake/make.py", line 32, in main
    subprocess.check_call([sys.executable, PYMAKE] + args)
  File "C:\mozilla-build\python27\lib\subprocess.py", line 511, in check_call
    raise CalledProcessError(retcode, cmd)


It seems the directory for platform.ini is missing, I'm not sure why though.
Attached patch Fix - v1 (obsolete) β€” β€” Splinter Review
This fixes win32, I've tested it live on the slave that was failing. For some reason $(shell awk ...) fails while `awk ...` works. Strange stuff.
Attachment #765567 - Flags: review?(mbanner)
Attached patch Fix - v2 β€” β€” Splinter Review
Ok, v1 was crap. After finding out the issue is that awk is msys awk which doesn't work, and $(AWK) is gawk, which does work, everything seems to work.

I've also added := to some vars, this cuts the awk calls in half.
Attachment #765567 - Attachment is obsolete: true
Attachment #765567 - Flags: review?(mbanner)
Attachment #765617 - Flags: review?(bugspam.Callek)
Attachment #765617 - Flags: review?(bugspam.Callek) → review+
https://hg.mozilla.org/comm-central/rev/da5a6f0f1847
https://hg.mozilla.org/releases/comm-aurora/rev/c7f34340e86d

I've taken the liberty to use a=bustage, this affects only calendar and I want to see the l10n builds show up soon.

Again leaving open until win32 builds show up.
Duplicate of this bug: 756116
I'm going to mark this one fixed. Some of the xpis have shown up, others are not but because of an outage in scl1.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.5
Comment on attachment 765617 [details] [diff] [review]
Fix - v2

Oh we might want to take this for beta, I'm not sure why it was working before there. Maybe because the l10n stuff works differently there.
Attachment #765617 - Flags: approval-calendar-beta?
Attachment #765617 - Flags: approval-calendar-aurora+
Attachment #765617 - Flags: approval-calendar-beta? → approval-calendar-beta?(mbanner)
Attachment #765617 - Flags: approval-calendar-beta?(mbanner) → approval-calendar-beta+
You need to log in before you can comment on or make changes to this bug.