Last Comment Bug 756116 - No windows l10n Lightning builds since 2012-05-10
: No windows l10n Lightning builds since 2012-05-10
Status: RESOLVED DUPLICATE of bug 884291
:
Product: Calendar
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 Windows 7
: -- critical with 3 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 755166 761259 763876 764537 764939 884291
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-17 09:09 PDT by Steffen Wilberg
Modified: 2013-06-20 15:28 PDT (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Steffen Wilberg 2012-05-17 09:09:28 PDT
There are no win32 Lightning nightly builds created since several days.

Last comm-central build is from 2012-05-10:
ftp://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/win32-xpi/

Last comm-aurora win32 build is from 2012-05-14:
ftp://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-aurora/win32-xpi/
Comment 1 Stefan Sitter 2012-05-18 08:28:27 PDT
Mac OS X nightly builds are missing for days too. comm-central since 12-May-2012, comm-aurora since 14-May-2012.

In addition no builds are reported to http://tinderbox.mozilla.org/showbuilds.cgi?tree=CalendarTrunk or http://tinderbox.mozilla.org/showbuilds.cgi?tree=Calendar-Aurora for any platform.
Comment 2 Jeff Grossman 2012-05-18 08:33:28 PDT
I don't think the tinderbox links work anymore.  They moved all of the build machines last week.  I think you have to use the following link now, but I do not see an option for the Calendar module.

https://tbpl.mozilla.org/
Comment 3 Mark Banner (:standard8, limited time in Dec) 2012-05-18 08:41:09 PDT
No, calendar is still on tinderbox. The buildbot master isn't accessible at the moment, I believe gozer is working on this.
Comment 4 Philippe M. Chiasson (:gozer) 2012-05-18 09:17:26 PDT
The buildbot is now publicly visible (read-only) here:

https://calendar-master.mozillalabs.com/
Comment 5 Philippe M. Chiasson (:gozer) 2012-05-18 09:19:14 PDT
The windows builder can't connect to the new calendar master because of bug 755166
Comment 6 Stefan Sitter 2012-05-22 10:00:42 PDT
It's now almost two weeks without any build. This definitely blocks development and testing work.
Comment 7 Philippe M. Chiasson (:gozer) 2012-05-22 10:42:00 PDT
Windows builder is back in business.
Comment 8 u331436 2012-05-23 09:01:39 PDT
I don't see any new Windows Lightning nightly here:  ftp://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/

Was there a glitch preventing the build ? apparently so.
Comment 9 Jeff Grossman 2012-05-23 11:43:04 PDT
According to https://calendar-master.mozillalabs.com/ it looks like Windows builds are succeeding but they are not available on the FTP site.  Where can we go to download these builds?
Comment 10 Philipp Kewisch [:Fallen] 2012-05-23 18:14:03 PDT
Windows builds are not all succeeding, they are getting unexpected connection failures. The hourly builds seem to be fine, but the nightly builds are failing:

https://calendar-master.mozillalabs.com/one_box_per_builder

I had the same thing for the win32_build builder doing the beta build and the second time around it just worked.


gozer, any idea whats happening here?
Comment 11 Philippe M. Chiasson (:gozer) 2012-05-24 11:03:17 PDT
Bumped up connection timeouts on the recieving side. You might also want to try and enable the buildbot ping interval option in the slave's buildbot.tac
Comment 12 Stefan Sitter 2012-05-25 11:03:13 PDT
cal-vm-win32-tbox seems online again but builds are still failing.

Any idea what happened to tb2-darwin10-slave64?
Was it moved or renamed or lost in the mozillamessaging to mozilla migration?
Comment 13 Philippe M. Chiasson (:gozer) 2012-05-25 12:21:05 PDT
(In reply to Stefan Sitter from comment #12)
> Any idea what happened to tb2-darwin10-slave64?
> Was it moved or renamed or lost in the mozillamessaging to mozilla migration?

It got left behind in the move to SCL3, as these models of Minis can't be installed there.

Calendar needs to request a new Mini (from the community folks, maybe?).
Comment 14 Stefan Sitter 2012-05-29 22:27:14 PDT
Current win32 status:

WINNT 5.2 comm-aurora lightning build: ok

WINNT 5.2 comm-central lightning build: failing (hg exception during hg checkout)

WINNT 5.2 comm-aurora lightning nightly: failing (connection lost during hg checkout)

WINNT 5.2 comm-central lightning nightly: failing (connection lost during hg checkout)

Anything you can do about this errors?

Where can I follow the progress regarding the new Mac OS X build server? Is this tracked by bug too?
Comment 15 Stefan Sitter 2012-06-06 12:23:06 PDT
Could someone CLOBBER the win32 builders? Maybe this fixes the current comm-aurora linker problem and the comm-central hg checkout problem?

When will the builds report back to http://tinderbox.mozilla.org/ again?
Comment 16 Philipp Kewisch [:Fallen] 2012-06-06 12:34:32 PDT
I wish I could. The clobberer is gone since the IT move. I can do it manually, but since the new win32 VM is ready I will probably just set things up there.

I'm sorry this is taking so long!
Comment 17 Gilberto Olimpio 2012-06-11 14:25:25 PDT
any progress?
cheers!
Comment 18 Philipp Kewisch [:Fallen] 2012-06-13 14:32:31 PDT
Windows machine is set up, we just need bug 764537 fixed for long term connectivity.
Comment 19 Ravi Abram 2012-06-19 04:50:40 PDT
ETA?
Comment 20 Mark Banner (:standard8, limited time in Dec) 2012-06-19 23:43:22 PDT
Quick update:

I think we've probably fixed the issue with the Windows builder dropping connections. Windows builds are suffering from buildbot issues, see bug 765806, work in progress.

Mac nightly builds with the SeaMonkey loaner box failed to upload due to issues with permissions. I've fixed those locally and will land in buildbot-configs once they are proven. Looks like we also still have a couple of issues with that box randomly dropping connections, but not during builds so far.
Comment 21 Mark Banner (:standard8, limited time in Dec) 2012-06-20 02:13:16 PDT
(In reply to Mark Banner (:standard8) from comment #20)
> Mac nightly builds with the SeaMonkey loaner box failed to upload due to
> issues with permissions.

Correction: The builds uploaded, but crash reporter symbols didn't. That should be fixed with this next build.

The builds can be found in the normal place:

http://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-comm-central/macosx-xpi/
Comment 22 Kent James (:rkent) 2012-06-22 13:16:58 PDT
Just as a FYI, I got tired of waiting for aurora Lightning, so I've built my own, in the process extending the build so that it can work with TB 13, 14, or 15. You can download this if you want. More information at http://mesquilla.com/2012/06/22/earlylight-an-unofficial-lightning-aurora-build-supporting-multiple-thunderbird-versions/
Comment 23 Ravi Abram 2012-06-25 07:20:04 PDT
Tried installing the Jun-25-2012 version with 16.a1 thunderbird.  Says it is incompatible.
Comment 24 Philipp Kewisch [:Fallen] 2012-06-25 07:57:43 PDT
Works for me, could you doublecheck your Thunderbird and Lightning version? Make sure its a 32 bit Thunderbird. What error do you get?
Comment 25 Ravi Abram 2012-06-25 08:06:34 PDT
Lightning Version: 1.6a1
Lightning obtained from: /pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/win32-xpi
OS: Windows 7 (64)
Comment 26 Sascha Grage 2012-06-25 08:09:12 PDT
(In reply to Ravi Abram from comment #23)
> Tried installing the Jun-25-2012 version with 16.a1 thunderbird.  Says it is
> incompatible.

Works for me: 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Thunderbird/16.0a1 ID:20120625030538 + 
http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/win32-xpi/
Comment 27 Philipp Kewisch [:Fallen] 2012-06-25 08:32:40 PDT
Ravi, what exact Thunderbird version do you have? (User Agent at least, or tell me if its 32 bit and also from latest-comm-central)
Comment 28 Ravi Abram 2012-06-25 08:48:37 PDT
Fixed. Needed 32bit and not 64bit. installed right away. hooray!
Comment 29 Peter Lairo 2012-06-26 03:59:09 PDT
m.d.a.calendar reported: "new comm-aurora and comm-central nightly builds showed up on the server with build date 2012-06-25"

I tried it and it did install (yay!), but it causes Thunderbird and Lightning to become completely unresponsive ("Not Responding" for 2+ hours). I do have a lot of CalDAV calendars (about 15); but a calendar app should be able to handle that easily. Therefore: Not Fixed.
Comment 30 Mark Banner (:standard8, limited time in Dec) 2012-06-26 04:15:37 PDT
(In reply to Peter Lairo from comment #29)
> m.d.a.calendar reported: "new comm-aurora and comm-central nightly builds
> showed up on the server with build date 2012-06-25"
> 
> I tried it and it did install (yay!), but it causes Thunderbird and
> Lightning to become completely unresponsive ("Not Responding" for 2+ hours).
> I do have a lot of CalDAV calendars (about 15); but a calendar app should be
> able to handle that easily. Therefore: Not Fixed.

Peter, as I'm sure you realise, the issue with not having nightly builds at all and nightly builds that are hanging are two different separate things. I admit I only gave it a brief try, but Lightning in nightly seemed to work for the basic operations. I suggest you let this be resolved fixed once we've finished the remaining work, and file a new bug with the details of your issue - there's been a lot of code changes in Thunderbird, Gecko and some in Lightning since the last nightly, so it is highly likely that it is one of those that is the cause.
Comment 31 Peter Lairo 2012-06-26 05:39:19 PDT
(In reply to Mark Banner (:standard8) from comment #30)
> > ...it causes Thunderbird and
> > Lightning to become completely unresponsive
> 
> I suggest you [...] file a new bug 

Agreed.

Update: After four hours of "Not Responding", the CPU usage finally went down and Thunderbird and Lightning are usable again (except that there are still very long 10-second lags when clicking to another week or month). I'll see if there is already a bug on that...
Comment 32 Tomasz Lipski 2012-06-28 02:22:14 PDT
I can see the win32 builds in latest-comm-central (not tested yet, though).
May I ask if there is any problem with win32 l10n builds as the latest versions are still from May?
Comment 33 Mark Banner (:standard8, limited time in Dec) 2012-06-28 02:30:42 PDT
I can confirm there's an issue with l10n builds still. Something isn't quite right in the repacks.

Philipp: can you take a look on the win32 box and see if lightning.xpi is being downloaded to the right place?
Comment 34 Stefan Sitter 2012-08-19 22:40:06 PDT
All Linux builds broken: bug 779192
All Mac OS X builds broken: bug 780376
Adjusting the summary to the remaining problem mentioned in Comment 32.
Comment 35 Philipp Kewisch [:Fallen] 2013-06-20 15:28:10 PDT
Hey Folks, thanks for all the discussion here. I'm sorry its been a year without l10n builds, but now that we are on new infrastructure things are getting better. I'm going to dupe this bug against bug 884291 since thats where the patches are happening.

*** This bug has been marked as a duplicate of bug 884291 ***

Note You need to log in before you can comment on or make changes to this bug.