Make gaia-central corresponding git commit discoverable from b2g/config/gaia.json

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: nbp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Currently b2g/config/gaia.json contains a reference to a mercurial changeset.  This changeset depends on the conversion made by hg-git which stores the mapping between changeset and commits into a map-file.

Ideally, we should modify the "Gaia Pushbot <release+gaiajson@mozilla.com>", such as it also add a reference to the sha1 in addition to the changeset.

An other solution would be to make the mapfile accessible to everybody through a ftp/http server.  This is not ideal as this would require people to do some network access to clone the full map-file.
Duplicate of this bug: 894726
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
Is there any ETA on this being available?

Updated

4 years ago
Summary: Make gaia-central corresponding commit discoverable from b2g/config/gaia.json → Make gaia-central corresponding git commit discoverable from b2g/config/gaia.json
This was fixed a while ago.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.