Move hosted partner bundles into place automatically

RESOLVED FIXED

Status

Release Engineering
Release Automation
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: coop, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [partners][release])

Attachments

(3 attachments, 1 obsolete attachment)

Mozilla hosts a small subset of repacks due to contractual reasons. Someone from releng currently needs to move these repacks into place by hand. The instructions are pretty straightforward, so it seems like something we could automate easily:

https://intranet.mozilla.org/Build:Partners:Repacks:Bundles
(Assignee)

Updated

4 years ago
Priority: -- → P3
This should probably be a higher priority, considering the manual build updates haven't been happening reliably.
(Assignee)

Comment 2

4 years ago
(In reply to Mike Connor [:mconnor] from comment #1)
> This should probably be a higher priority, considering the manual build
> updates haven't been happening reliably.

Agreed.

This can probably be implemented as an additional function of stage-tasks.py, which already does similar things. We'd need to support a 'partnerbundle' or similar in the args, and then write a method like https://github.com/mozilla/build-tools/blob/master/scripts/release/stage-tasks.py#L111, which does the work.

The only real question is where to store the list of file copies. Maybe it's OK to just hardcode it in stage-tasks.py, since we only have the one?
Depends on: 894029
(In reply to Ben Hearsum [:bhearsum] from comment #2) 
> The only real question is where to store the list of file copies. Maybe it's
> OK to just hardcode it in stage-tasks.py, since we only have the one?

We actually have two, the docs are just crap. 

I'm updating the docs now so it will be trivial to script up after.
(Assignee)

Updated

4 years ago
Priority: P3 → --
(Assignee)

Comment 4

4 years ago
Created attachment 782678 [details] [diff] [review]
add ability to sync partner bundles

This is just automation of https://wiki.mozilla.org/Release:Release_Automation_on_Mercurial:Updates_through_Shipping#Update_hosted_partner_bundles.

Need to adjust a couple of release configs, too.
Assignee: nobody → bhearsum
Status: NEW → ASSIGNED
Attachment #782678 - Flags: review?(rail)
(Assignee)

Comment 5

4 years ago
Created attachment 782680 [details] [diff] [review]
enable bundle syncing for firefox on mozilla-release
Attachment #782680 - Flags: review?(rail)
Attachment #782680 - Flags: review?(rail) → review+
Comment on attachment 782678 [details] [diff] [review]
add ability to sync partner bundles

Review of attachment 782678 [details] [diff] [review]:
-----------------------------------------------------------------

::: lib/python/release/paths.py
@@ -10,5 @@
> -    # fennec/nightly
> -    if product == 'fennec':
> -        product = 'mobile'
> -        if not nightlyDir:
> -            nightlyDir = 'candidates'

This hunk will break Fennec, since productName is not "mobile" for it. Using stage_product would be better.
Attachment #782678 - Flags: review?(rail) → review-
(Assignee)

Comment 7

4 years ago
Created attachment 783729 [details] [diff] [review]
fix makeCandidatesDir regression
Attachment #782678 - Attachment is obsolete: true
Attachment #783729 - Flags: review?(rail)
Comment on attachment 783729 [details] [diff] [review]
fix makeCandidatesDir regression

tests incoming
Attachment #783729 - Flags: review?(rail) → review+
Created attachment 783757 [details] [diff] [review]
tests
Attachment #783757 - Flags: review?(bhearsum)
(Assignee)

Updated

4 years ago
Attachment #783757 - Flags: review?(bhearsum) → review+
(Assignee)

Updated

4 years ago
Attachment #783729 - Flags: checked-in+
(Assignee)

Updated

4 years ago
Attachment #783757 - Flags: checked-in+
(Assignee)

Comment 10

4 years ago
Comment on attachment 782680 [details] [diff] [review]
enable bundle syncing for firefox on mozilla-release

I updated the real config too, since the release has already started.
Attachment #782680 - Flags: checked-in+
(Assignee)

Comment 11

4 years ago
Landed, and I moved the FIREFOX_23_0_RELEASE tag so that this is picked up during its postrelease. I will be PTO at that time, Rail agreed to be on the hook in case something breaks.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
in production
Product: mozilla.org → Release Engineering
(Assignee)

Updated

3 years ago
Duplicate of this bug: 809174
You need to log in before you can comment on or make changes to this bug.