(australis) Icons too large, rendering them ugly

RESOLVED WORKSFORME

Status

()

Firefox
Theme
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Markus Popp, Unassigned)

Tracking

({regression})

Trunk
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Australis:M?][Australis:P2])

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
Created attachment 765030 [details]
Icons with Australis UI

Icons with Australis UI are too large, making them somewhat blurry, certainly ugly. See screenshots.
(Reporter)

Comment 1

5 years ago
Created attachment 765032 [details]
Same icons, current UI (without Australis)

For comparison, here is what the icons look like now, without Australis (same scale)

Updated

5 years ago
Blocks: 863299
Keywords: regression
Whiteboard: [Australis:M?]
P2 on the assumption this is Linux-wide.
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P2]

Comment 3

5 years ago
Created attachment 766447 [details]
Large icons on windows.

Some of the toolbarbuttons have large icons on windows.

When placed in the navbar they expand the height of it (see screenshot).

The large toolbarbuttons in the screenshot have the following two attributes (the toolbarbuttons with small icons do not):
"widget-id"
"widget-type"

The following toolbarbuttons have icons that are too large:
"Open file"
"Save this page"
"Open a new Private Browsing window"
"Add-ons manager"
"Toggle Developer Tools"
"Preferences..."
"Find in this page"
(Reporter)

Comment 4

5 years ago
Bug 828819 may also be worth considering along with this issue.
Is this bug (purely about the size) actually still reproducible with the latest version of UX? The icons are still not the ones we want to have on Linux in the final version - still waiting for those - but the sizing problem should be fixed now. Markus, is that correct?
Flags: needinfo?(markus.popp)
(Reporter)

Comment 6

5 years ago
Created attachment 771657 [details]
Addon icons in July 5 UX builds.

Here is what they look like in today's UX Nightly.
Flags: needinfo?(markus.popp)
(In reply to Markus Popp from comment #6)
> Created attachment 771657 [details]
> Addon icons in July 5 UX builds.
> 
> Here is what they look like in today's UX Nightly.

OK. That looks OK to me considering that small icons mode was removed. Trunk looks the same when you switch to large icons mode. The reason the add-on icons are now small is probably that you used the same profile on (normal, trunk) Nightly at some point, switched back to small icons mode (because UX migrates that and turns it off), and the add-on icons still have CSS rules for that, but actual trunk doesn't.

Based on that and the UX built-in icons looking the way they should, marking this WFM.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.