exception in contacts sidebar when clicking contact

RESOLVED DUPLICATE of bug 343973

Status

Thunderbird
Address Book
RESOLVED DUPLICATE of bug 343973
5 years ago
4 years ago

People

(Reporter: Magnus Melin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 765267 [details] [diff] [review]
proposed fix

I have no idea why i'm only seeing this in one of my profiles. 

In the compose window, F9 (to get the contacts sidebar), click contact. Then look at the error console

Error: An error occurred updating the cmd_delete command: [Exception... "'[JavaScript Error: "goSetMenuValue is not defined" {file: "chrome://messenger/content/addressbook/abResultsPane.js" line: 373}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 75"  data: yes]

Anyways, http://mxr.mozilla.org/comm-central/source/mailnews/addrbook/content/abResultsPane.js#373 calls goSetMenuValue which is in globalOverlay.js - but that hasn't been imported to that page.

(I assume it bubbles up to the window level, where globalOverlay.js is imported. It's irony having code in globalOverlay.js saying code in globalOverlay.js wasn't defined)
Attachment #765267 - Flags: review?(mconley)
(Reporter)

Comment 1

4 years ago
Comment on attachment 765267 [details] [diff] [review]
proposed fix

Review of attachment 765267 [details] [diff] [review]:
-----------------------------------------------------------------

aceman is fixing this same exception in bug 343973. 
Still a mystery why i don't see it in all profiles though.
Attachment #765267 - Flags: review?(mconley)
(Reporter)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 343973
(Reporter)

Updated

4 years ago
Assignee: mkmelin+mozilla → nobody
You need to log in before you can comment on or make changes to this bug.