Closed Bug 885294 Opened 9 years ago Closed 8 years ago

Immediate script selection from debugger search box is really janky and loses selection if you don't find anything

Categories

(DevTools :: Debugger, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 29

People

(Reporter: Gijs, Assigned: vporof)

References

Details

Attachments

(1 file)

If I use the browser debugger, generally, script selection using the filter in the top right is really janky, because it seems to update the content view non-stop. This is very visually jarring. I don't think it should change until you hit enter, or until you actually start navigating the autocomplete list.

This is at its worst when I accidentally filter scripts rather than using 'find in this script', which makes me lose the script I had selected originally, meaning I have to re-filter to get back to it, and then do another search to do what I originally meant to do.
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Priority: -- → P3
Depends on: 881219
Duplicate of this bug: 945909
When searching for files and functions, the first match isn't automatically selected anymore.
Attachment #8355788 - Flags: review?(past)
Depends on: 943883
Comment on attachment 8355788 [details] [diff] [review]
dbg-no-auto-select.patch

Review of attachment 8355788 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM.
Attachment #8355788 - Flags: review?(past) → review+
https://hg.mozilla.org/mozilla-central/rev/7f48035ecdb4
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.