Defect - Occasionally while running tests the browser never paints

RESOLVED FIXED

Status

defect
P2
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

According to prelim mochiperf test results, on about 1 out of every 10 test runs MozAfterPaint never fires for a slew of tests.

In the same logs for these runs delay load never finishes, which is probably be related.

bad run:
-------------------------------------------------------------
https://tbpl.mozilla.org/php/getParsedLog.php?id=24486654&tree=Mozilla-Inbound&full=1

22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Opening about:mozilla in a new tab
22:51:43     INFO -  ### Content.js loaded
22:51:43     INFO -  ### FormHelper.js loaded
22:51:43     INFO -  ### SelectionPrototype.js loaded
22:51:43     INFO -  ### SelectionHandler.js loaded
22:51:43     INFO -  ### ContextMenuHandler.js loaded
22:51:43     INFO -  ### FindHandler.js loaded
22:51:43     INFO -  ### ConsoleAPIObserver.js loaded
22:51:43     INFO -  MetroWidget::GetDPI
22:51:43     INFO -  MetroWidget::GetDPI
22:51:43     INFO -  TEST-PASS | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | about:mozilla is loaded
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 5000ms
22:51:43     INFO -  * delay load started...
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371966702385	Sync.Tracker.Clients	WARN	Changed IDs file clients contains non-object value.
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371966702397	Sync.Tracker.History	WARN	Changed IDs file history contains non-object value.
..
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 501ms
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 502ms
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | PERF-TEST | DECLARE {"id":"ecb5fbec-0b3d-490f-8d4a-13fa8963e54a","version":"1","name":"shift browser deck","category":"browser","subcategory":"ux","description":"Triggers multiple SKB deck shifting operations using an offset value of 300px. Measures total time in milliseconds for a up/down shift operation plus the total number of paints. Strips outliers.","buildid":"20130622221301"}
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | PERF-TEST | RESULTS {"id":"ecb5fbec-0b3d-490f-8d4a-13fa8963e54a","version":"1","results":{"r0":{"value":635.7465402111201,"desc":"msec"},"r1":{"value":0,"desc":"paint count"}}}


good run:
-------------------------------------------------------------
https://tbpl.mozilla.org/php/getParsedLog.php?id=24480861&tree=Mozilla-Inbound&full=1

22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Opening about:mozilla in a new tab
22:51:43     INFO -  ### Content.js loaded
22:51:43     INFO -  ### FormHelper.js loaded
22:51:43     INFO -  ### SelectionPrototype.js loaded
22:51:43     INFO -  ### SelectionHandler.js loaded
22:51:43     INFO -  ### ContextMenuHandler.js loaded
22:51:43     INFO -  ### FindHandler.js loaded
22:51:43     INFO -  ### ConsoleAPIObserver.js loaded
22:51:43     INFO -  MetroWidget::GetDPI
22:51:43     INFO -  MetroWidget::GetDPI
22:51:43     INFO -  TEST-PASS | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | about:mozilla is loaded
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 5000ms
22:51:43     INFO -  * delay load started...
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371966702385	Sync.Tracker.Clients	WARN	Changed IDs file clients contains non-object value.
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371966702392	Sync.Tracker.Bookmarks	WARN	Changed IDs file bookmarks contains non-object value.
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371966702394	Sync.Tracker.Forms	WARN	Changed IDs file forms contains non-object value.
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371966702397	Sync.Tracker.History	WARN	Changed IDs file history contains non-object value.
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371966702399	Sync.Tracker.Passwords	WARN	Changed IDs file passwords contains non-object value.
22:51:43     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: [timing] start: 762ms
..
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | PERF-TEST | DECLARE {"id":"ecb5fbec-0b3d-490f-8d4a-13fa8963e54a","version":"1","name":"shift browser deck","category":"browser","subcategory":"ux","description":"Triggers multiple SKB deck shifting operations using an offset value of 300px. Measures total time in milliseconds for a up/down shift operation plus the total number of paints. Strips outliers.","buildid":"20130622221301"}
22:51:58     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | PERF-TEST | RESULTS {"id":"ecb5fbec-0b3d-490f-8d4a-13fa8963e54a","version":"1","results":{"r0":{"value":635.7465402111201,"desc":"msec"},"r1":{"value":0,"desc":"paint count"}}}
Here's the right good run:
-------------------------------------------------------------
https://tbpl.mozilla.org/php/getParsedLog.php?id=24483442&tree=Mozilla-Inbound&full=1

20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Opening about:mozilla in a new tab
20:30:45     INFO -  ### Content.js loaded
20:30:45     INFO -  ### FormHelper.js loaded
20:30:45     INFO -  ### SelectionPrototype.js loaded
20:30:45     INFO -  ### SelectionHandler.js loaded
20:30:45     INFO -  ### ContextMenuHandler.js loaded
20:30:45     INFO -  ### FindHandler.js loaded
20:30:45     INFO -  ### ConsoleAPIObserver.js loaded
20:30:45     INFO -  MetroWidget::GetDPI
20:30:45     INFO -  MetroWidget::GetDPI
20:30:45     INFO -  TEST-PASS | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | about:mozilla is loaded
20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 5000ms
20:30:45     INFO -  * delay load started...
20:30:45     INFO -  * delay load complete.
20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371958244224	Sync.Tracker.Clients	WARN	Changed IDs file clients contains non-object value.
20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371958244230	Sync.Tracker.Bookmarks	WARN	Changed IDs file bookmarks contains non-object value.
20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371958244232	Sync.Tracker.Forms	WARN	Changed IDs file forms contains non-object value.
20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371958244235	Sync.Tracker.History	WARN	Changed IDs file history contains non-object value.
20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: 1371958244237	Sync.Tracker.Passwords	WARN	Changed IDs file passwords contains non-object value.
20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: [timing] start: 827ms
20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: [timing] main: 844ms
20:30:45     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: [timing] startupCrashDetectionBegin: 966ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: [timing] firstPaint: 2983ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: [timing] sessionRestored: 2346ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: [timing] createTopLevelWindow: 1517ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Console message: [timing] firstLoadURI: 4331ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 5001ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 501ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 501ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 501ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 503ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 501ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 501ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 501ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 502ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 502ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | Wating for 500ms
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | PERF-TEST | DECLARE {"id":"ecb5fbec-0b3d-490f-8d4a-13fa8963e54a","version":"1","name":"shift browser deck","category":"browser","subcategory":"ux","description":"Triggers multiple SKB deck shifting operations using an offset value of 300px. Measures total time in milliseconds for a up/down shift operation plus the total number of paints. Strips outliers.","buildid":"20130622194901"}
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | PERF-TEST | RESULTS {"id":"ecb5fbec-0b3d-490f-8d4a-13fa8963e54a","version":"1","results":{"r0":{"value":624.8351571645339,"desc":"msec"},"r1":{"value":102.33333333333333,"desc":"paint count"}}}
20:31:00     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | END deck offset
20:31:22     INFO -  TEST-INFO | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | waitForMs finished waiting, waited for 505ms
20:31:22     INFO -  INFO TEST-END | chrome://mochitests/content/metro/browser/metro/base/tests/mochiperf/browser_deck_01.js | finished in 16427ms
Our app info data shows something pretty serious is going wrong - 

good:

[timing] start: 827ms
[timing] main: 844ms
[timing] startupCrashDetectionBegin: 966ms
[timing] firstPaint: 2983ms
[timing] sessionRestored: 2346ms
[timing] createTopLevelWindow: 1517ms
[timing] firstLoadURI: 4331ms

bad:

[timing] start: 762ms
[timing] main: 771ms
[timing] startupCrashDetectionBegin: 926ms
[timing] firstPaint: 23232ms
[timing] sessionRestored: 22345ms
[timing] createTopLevelWindow: 1579ms
[timing] firstLoadURI: 24430ms


Looks like this is related to Talos startup bug 859571.
Elapsed time for the test run looks ok, doesn't appear to be browser related:

22:48:02.504166
22:54:40.321275

https://tbpl.mozilla.org/php/getParsedLog.php?id=24483442&tree=Mozilla-Inbound&full=1
(In reply to Jim Mathies [:jimm] from comment #3)
> Elapsed time for the test run looks ok, doesn't appear to be browser related:
> 
> 22:48:02.504166
> 22:54:40.321275
> 
> https://tbpl.mozilla.org/php/getParsedLog.php?id=24483442&tree=Mozilla-
> Inbound&full=1

Although this doesn't seem to jibe with app info first paint times of 23232ms!
Depends on: 859571
Depends on: 886149
Summary: Occasionally while running tests the browser never paints → Defect - Occasionally while running tests the browser never paints
Whiteboard: feature=defect c=tbd u=tbd p=0
Quick update here, based on some additional logging in Timestamp I believe this 20 second delay is real and not some mathematical flaw in our timestamping code.

I can reproduce this pretty easily, however when I turned on some nspr logging for networking with timestamps the problem went away - 

https://tbpl.mozilla.org/?tree=Try&showall=0&rev=6eaf404deb08

Not sure why that is yet. There no nsSocketTransport activity on startup so I think we can rule out networking issues at this point.
Posted patch experimental work around (obsolete) — Splinter Review
This is an experimental work around based on some testing I've been doing using try and nspr logging. It's not a fix. I'd like to confirm this does in fact address the problem over a period of a day or two for inbound checkins.
Assignee: nobody → jmathies
Attachment #767314 - Flags: review?(netzen)
Comment on attachment 767314 [details] [diff] [review]
experimental work around

Review of attachment 767314 [details] [diff] [review]:
-----------------------------------------------------------------

No idea of why this would help but since it's experimental I see no harm.
Attachment #767314 - Flags: review?(netzen) → review+
Posted patch debug timestamp wip (obsolete) — Splinter Review
(In reply to Brian R. Bondy [:bbondy] from comment #7)
> Comment on attachment 767314 [details] [diff] [review]
> experimental work around
> 
> Review of attachment 767314 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> No idea of why this would help but since it's experimental I see no harm.

I'm not sure yet either, could be a bug in our timestamp code or a bug in win8. Calling PR_Now before our timestamp coded initializes seems to fix it. PR_Now does a lot of calibration work on the first call, so I think there's something in there that straightens things out.

We'll see, I might have gotten lucky on my series of try pushes. A day or two on inbound will show whether this work around is valid or not.
Whiteboard: feature=defect c=tbd u=tbd p=0 → [leave-open] feature=defect c=tbd u=tbd p=0
One of the things PR_Now does when it initializes is call timeBeginPeriod(1)/timeEndPeriod(1). I'd bet money that's the "thing" that gets things running smoothly.

http://mxr.mozilla.org/mozilla-central/source/nsprpub/pr/src/md/windows/ntmisc.c#85

related:

bug 590422
bug 866561
Blocks: metrov1it10
No longer blocks: metrov1defect&change
Status: NEW → ASSIGNED
QA Contact: jbecerra
Whiteboard: [leave-open] feature=defect c=tbd u=tbd p=0 → [leave-open] feature=defect c=tbd u=tbd p=8
Could this be related to some issue with bug 836869?
(In reply to Honza Bambas (:mayhemer) from comment #12)
> Could this be related to some issue with bug 836869?

Not sure, we're dealing with a twenty second offset, which seems pretty large compared to the numbers you discuss there.
(In reply to Jim Mathies [:jimm] from comment #10)
> https://hg.mozilla.org/integration/mozilla-inbound/rev/848dc57b455b

This didn't fix the issue. I must have been lucky on try. I'll back this out and do some more logging of try pushes.
(In reply to Jim Mathies [:jimm] from comment #13)
> (In reply to Honza Bambas (:mayhemer) from comment #12)
> > Could this be related to some issue with bug 836869?
> 
> Not sure, we're dealing with a twenty second offset, which seems pretty
> large compared to the numbers you discuss there.

FWIW, your checkin there didn't effect the Talos issue in bug 859571.
Attachment #767314 - Attachment is obsolete: true
Attachment #767317 - Attachment is obsolete: true
Please backout cset 848dc57b455b whenever it's convenient. (comment 10)
Keywords: checkin-needed
(In reply to Ryan VanderMeulen [:RyanVM UTC-4][PTO 6/27-6/30] from comment #18)
> Backed out.
> https://hg.mozilla.org/integration/mozilla-inbound/rev/12e09c549363

Backout merged:
https://hg.mozilla.org/mozilla-central/rev/12e09c549363
Initial data indicates turning on OMTC has reduces the occurrence of this quite a bit. We'll see how things look in a few days, we may be able to resolve this one out.
(In reply to Jim Mathies [:jimm] from comment #20)
> Initial data indicates turning on OMTC has reduces the occurrence of this
> quite a bit. We'll see how things look in a few days, we may be able to
> resolve this one out.

I spoke too soon, we just had a good run on inbound for a while.
It does seem as though turning on nspr logging and adding 'timestamp' as a module fixes the problem. Which sucks since it means we can use nspr timstamping to diagnose.
(In reply to Jim Mathies [:jimm] from comment #22)
> It does seem as though turning on nspr logging and adding 'timestamp' as a
> module fixes the problem. Which sucks since it means we can use nspr
> timstamping to diagnose.

*can't use nspr timing to diagnoe. :/
(In reply to Jim Mathies [:jimm] from comment #2)
> Our app info data shows something pretty serious is going wrong - 
> 
> good:
> 
> [timing] start: 827ms
> [timing] main: 844ms
> [timing] startupCrashDetectionBegin: 966ms
> [timing] firstPaint: 2983ms
> [timing] sessionRestored: 2346ms
> [timing] createTopLevelWindow: 1517ms
> [timing] firstLoadURI: 4331ms
> 
> bad:
> 
> [timing] start: 762ms
> [timing] main: 771ms
> [timing] startupCrashDetectionBegin: 926ms
> [timing] firstPaint: 23232ms
> [timing] sessionRestored: 22345ms
> [timing] createTopLevelWindow: 1579ms
> [timing] firstLoadURI: 24430ms
> 
> 
> Looks like this is related to Talos startup bug 859571.

Whatever was causing this seems to have gone away for our mochitest runs over the last couple weeks - 
http://www.mathies.com/mozilla/mochiperf.html?testid=5F2A456E-2BB2-4073-A751-936F222FEAE0

But the missing MozAfterPaints remain, so potentially these two issues were unrelated.
Blocks: metrov1it11
No longer blocks: metrov1it10
Assignee: jmathies → nobody
Blocks: metrov1defect&change
No longer blocks: metrov1it11
QA Contact: jbecerra
Whiteboard: [leave-open] feature=defect c=tbd u=tbd p=8 → [leave-open] feature=defect c=tbd u=tbd p=0
Status: ASSIGNED → NEW
Whiteboard: [leave-open] feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=0 [leave-open]
Whiteboard: feature=defect c=tbd u=tbd p=0 [leave-open] → feature=defect c=tbd u=tbd p=0 [leave-open][preview-triage]
preview- for now as it appears to be an issue with our slaves. I think we have a fix to bug 859571 in the works too which might address this.
Whiteboard: feature=defect c=tbd u=tbd p=0 [leave-open][preview-triage] → feature=defect c=tbd u=tbd p=0 [leave-open][preview-]
Blocks: 896711
Whiteboard: feature=defect c=tbd u=tbd p=0 [leave-open][preview-] → feature=defect c=tbd u=tbd p=0
See the parent bug, this was due to a slave config issue.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
No longer blocks: metrov2defect&change, 896711
Whiteboard: feature=defect c=tbd u=tbd p=0
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.