Closed Bug 886227 Opened 7 years ago Closed 6 years ago

Intermittent TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/social/browser_addons.js | uncaught exception - TypeError: navigator.mozSocial is undefined at /test/social/social_s

Categories

(Firefox Graveyard :: SocialAPI, defect)

x86
Windows 7
defect
Not set

Tracking

(firefox24 fixed, firefox25 fixed)

RESOLVED FIXED
Firefox 25
Tracking Status
firefox24 --- fixed
firefox25 --- fixed

People

(Reporter: cbook, Assigned: mixedpuppy)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=24503203&tree=Mozilla-Inbound

WINNT 6.2 mozilla-inbound debug test mochitest-browser-chrome on 2013-06-23 20:09:03 PDT for push 9661a68f0bff

slave: t-w864-ix-013

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/social/browser_addons.js | uncaught exception - TypeError: navigator.mozSocial is undefined at https://test1.example.com/browser/browser/base/content/test/social/social_sidebar.html:7
20:18:35     INFO -  Stack trace:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a257161ff235
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Reopened because bug 872605 was relanded, and then this started happening again.
Assignee: nobody → mixedpuppy
Blocks: 872605
Flags: needinfo?(mixedpuppy)
unable to reproduce locally, testing a possible fix in try

https://tbpl.mozilla.org/?tree=Try&rev=c3fc4ed90a38
Flags: needinfo?(mixedpuppy)
The test fix in the previous try seems to address the issue.  This patch takes a closer look at handling an edge case in the code.

https://tbpl.mozilla.org/?tree=Try&rev=f24188da3f1e

If this appears to fix the issue, I'm inclined to land both patches together.
I was able to reliably reproduce the orange on top of some other patches being worked on in bug 889427.  This is the combined patch from the other two that fixed it locally, lets see what try does for us.

https://tbpl.mozilla.org/?tree=Try&rev=b9d4812089b4
Attachment #781226 - Flags: review?(mhammond)
Attachment #781226 - Flags: review?(mhammond) → review+
for whatever reason, last try didn't run, new try (unfortunately also have to bypass test breakage from bug 865349):

https://tbpl.mozilla.org/?tree=Try&rev=6c9c19ad834a
https://hg.mozilla.org/mozilla-central/rev/c00aa70e8318
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Comment on attachment 781226 [details] [diff] [review]
fix intermittent failure

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 872605
User impact if declined: none
Testing completed (on m-c, etc.): inbound/m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none

I've only seen the intermittent orange on aurora since this landed, would be nice to get rid of those too.
Attachment #781226 - Flags: approval-mozilla-aurora?
Comment on attachment 781226 [details] [diff] [review]
fix intermittent failure

low risk patch to avoid intermittent oranges
Attachment #781226 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.