Major slowdown when scrolling the same HTML page with SVG images instead of PNG ones

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
4 years ago
3 months ago

People

(Reporter: Julien Sanchez, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [in-the-wild] [external-report], URL)

(Reporter)

Description

4 years ago
Scrolling a page with SVG elements is very slow.

Testcase from ‏@chriscoyier:
http://codepen.io/adrianosmond/pen/LCogn

This testcase is interesting to investigate the reason of the slowdown because it compares scrolling of a page with SVG images against the same one but with PNG images only.
Confirmed with nightly 24.0a1 (June 24) running on Ubuntu 12.04.  Also, chrome exhibits the same behavior.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

4 years ago
The codepen.io page is quite difficult to debug. I created a smaller testcase at: philbit.com/sprites2.html
(Reporter)

Comment 3

4 years ago
I have added Philip Roger's testcase as bug's main URL reference. The SVG-only container is almost impossible to scroll on my system whereas PNG version scrolls smoothly.
I'd expect that this is something Seth's recent work on SVG images would fix/improve. CC'ing Seth for his thoughts.
Keywords: perf
just noticed a fix for this issue has landed in chromium: https://code.google.com/p/chromium/issues/detail?id=253091
I tested Philip's testcase on my local build with the in-progress fix for bug 764299, and performance is much better. I've added that bug as a blocker.
Depends on: 764299
Duplicate of this bug: 887730

Updated

4 years ago
Whiteboard: [in-the-wild] [external-report]
another test (using CSS animations) just to confirm that performance on 29.0a2 is way better than it used to be a few months ago - SVG as img[src]: http://jsbin.com/bixun/1 and SVG as background-image: http://jsbin.com/bixun/3

Updated

3 months ago
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.