Closed Bug 886295 Opened 7 years ago Closed 6 years ago

Printer error pop-up when printing PDF

Categories

(Core :: Printing: Output, defect, critical)

24 Branch
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla25
Tracking Status
firefox23 --- unaffected
firefox24 + verified
firefox25 --- verified

People

(Reporter: epinal99-bugzilla2, Assigned: roc)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file, 1 obsolete file)

STR:
1) Open PDF http://excerpts.numilog.com/books/2297001363.pdf
2) Print (e.g. with MS Document XPS Writer)

Result: Printer error pop-up during printing, and the print is not created locally.

Regression range:
good=2013-06-19
bad=2013-06-20
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d2a7cfa34154&tochange=8ea92aeab783

Suspected bug:
Robert O'Callahan — Bug 880854. Part 2: Support reflows/frame reconstruction in print/print-preview documents by promoting them to frame reconstruction of the whole document. r=mats
Does this happen with a lot of pdf's or a few that are specially crafted ?
Assignee: nobody → roc
(In reply to bhavana bajaj [:bajaj] from comment #1)
> Does this happen with a lot of pdf's or a few that are specially crafted ?

I dunno, I just tested this one. But there was no issue to print it until 2013-06-20.
This is quite hard to fix. I think we should just back out the fix for bug 880854. I'll explain more over there.
Attached patch backout (obsolete) — Splinter Review
Attachment #770021 - Flags: review?(matspal)
Severity: normal → critical
Crash Signature: [@ nsPrintEngine::PrePrintPage()]
Keywords: crash
OS: Windows 7 → All
Hardware: x86_64 → All
Crash Signature: [@ nsPrintEngine::PrePrintPage()] → [@ nsPrintEngine::PrePrintPage() ]
Duplicate of this bug: 891125
Automation test should be provided.
Comment on attachment 770021 [details] [diff] [review]
backout

Bug 880854 part 2 only changes 5 files:
http://hg.mozilla.org/mozilla-central/rev/775a172255b1

It seems there are unrelated changes in this patch.
Attachment #770021 - Flags: review?(matspal) → review-
Blocks: 892960
Attached patch correct patchSplinter Review
I had attached the wrong patch, sorry
Attachment #770021 - Attachment is obsolete: true
Attachment #775073 - Flags: review?(matspal)
Comment on attachment 775073 [details] [diff] [review]
correct patch

r=mats
Attachment #775073 - Flags: review?(matspal) → review+
Comment on attachment 775073 [details] [diff] [review]
correct patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 880854
User impact if declined: bad failures to print under various circumstances (e.g. some pages with downloadable fonts)
Testing completed (on m-c, etc.): none. Just a backout.
Risk to taking this patch (and alternatives if risky): Low risk. Just a backout.
String or IDL/UUID changes made by this patch: none
Attachment #775073 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/7848493ca3f0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
Attachment #775073 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Needs a branch-specific patch for uplift.
Flags: needinfo?(roc)
QA Contact: jbecerra
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (Windows NT 6.2; rv:24.0) Gecko/20100101 Firefox/24.0

Verified as fixed on Firefox 24 beta 6 (buildID: 20130826142034) and latest Nightly (buildID: 20130826190748).
Bogdan, please verify this is fixed in Firefox 25.
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:25.0) Gecko/20100101 Firefox/25.0

Also verified as fixed on latest Aurora 25.0a2 (buildID: 20130910004002).
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.