Swiped words not appearing when using Google Keyboard

VERIFIED FIXED in Firefox 25

Status

()

VERIFIED FIXED
5 years ago
2 years ago

People

(Reporter: bnicholson, Assigned: jchen)

Tracking

Trunk
Firefox 25
All
Android
Points:
---

Firefox Tracking Flags

(firefox22 affected, firefox23 affected, firefox24 affected, firefox25 verified, fennec+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
STR:
1) Open AwesomeScreen
2) Swipe "Firefox"
3) Swipe "beta"

The "beta" I swipe does not appear in the URL bar, and only a space is entered. In other words, instead of seeing "Firefox beta", I only see "Firefox ".

This is on a Droid RAZR (4.1.2) with Google Keyboard from the Play Store. Not sure if this is a phone-specific issue or an issue with the Google Keyboard app.
Assignee: nobody → nchen
tracking-fennec: ? → +
(Assignee)

Updated

5 years ago
Duplicate of this bug: 893668
(Assignee)

Comment 2

5 years ago
Created attachment 776447 [details] [diff] [review]
Work around Google gesture keyboard quirk (v1)

When swiping a word, the Google keyboard first commits a space, then it sets the composition string to the new word. The problem is, we reset the keyboard after the space to switch to search mode, but because of the reset, the composition string is never set.

This patch delays resetting the keyboard to after setting the composition string, by ignoring the space, and (when using gesture keyboards) allowing resetting the keyboard even if there is a composition string.
Attachment #776447 - Flags: review?(cpeterson)
Comment on attachment 776447 [details] [diff] [review]
Work around Google gesture keyboard quirk (v1)

Review of attachment 776447 [details] [diff] [review]:
-----------------------------------------------------------------

Have you tested this with other gesture keyboards, like Swype or SwiftKey?
(Assignee)

Comment 4

5 years ago
(In reply to Chris Peterson (:cpeterson) from comment #3)
> Comment on attachment 776447 [details] [diff] [review]
> Work around Google gesture keyboard quirk (v1)
> 
> Review of attachment 776447 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Have you tested this with other gesture keyboards, like Swype or SwiftKey?

Yes
Status: NEW → ASSIGNED
Comment on attachment 776447 [details] [diff] [review]
Work around Google gesture keyboard quirk (v1)

Review of attachment 776447 [details] [diff] [review]:
-----------------------------------------------------------------

Just making sure. (I use Swype.) ;)

LGTM!
Attachment #776447 - Flags: review?(cpeterson) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d428ab19f2c7
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Beta/Aurora?
Status: RESOLVED → VERIFIED
status-firefox25: affected → verified
You need to log in before you can comment on or make changes to this bug.