Closed Bug 886853 Opened 7 years ago Closed 6 years ago

Can't edit whines with system TZ set to UTC timezone

Categories

(Bugzilla :: Whining, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 890563

People

(Reporter: dhlocker, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Running Ubuntu Server 12.04; Bugzilla 4.4; Apache 2.2; MySQL 5.5.31
sudo dpkg-reconfigure tzdata # set timezone to "Etc/UTC" (or Etc/GMT or UTC or Zulu)
Administration -> Whining


Actual results:

Software error:

Can't locate object method "now" via package "DateTime" at /var/www/bugzilla/editwhines.cgi line 386.



Expected results:

when dpgk-reconfigure tzdata # set timezone to US/Michigan, normal whining configuration page is displayed.
Me too getting same error on Bugzilla 4.4 on Ubuntu 12.04 when I click on 'Whining' option under Administration.

"Software error:
Can't locate object method "now" via package "DateTime" at
/var/www/bugzilla/editwhines.cgi line 386."


Installed the perl module 'libdatetime-perl' with apt-get install, 
Installed Perl -MCPAN -e 'install Bundle::DateTime::Complete'
re-compiled the bugzilla, but still getting same error.

Any other dependencies missing for this error?
Fixed in Bugzilla 4.4.1.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 890563
You need to log in before you can comment on or make changes to this bug.