Closed Bug 886999 Opened 7 years ago Closed 6 years ago

I10t 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js,test_nested_eventloop.html,test_bug509244.html,test_showModalDialog.html,869038.html | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62]

Categories

(Core :: Graphics: Layers, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla27
Tracking Status
firefox26 --- disabled
firefox27 --- fixed
firefox-esr24 --- unaffected
b2g-v1.2 --- disabled

People

(Reporter: RyanVM, Assigned: mstange)

References

Details

(Keywords: crash, intermittent-failure, Whiteboard: [qa-])

Crash Data

Attachments

(3 files, 3 obsolete files)

https://tbpl.mozilla.org/php/getParsedLog.php?id=24568436&tree=Mozilla-Inbound

Rev5 MacOSX Mountain Lion 10.8 mozilla-inbound opt test crashtest on 2013-06-25 08:02:47 PDT for push 2c9674fbea6a
slave: talos-mtnlion-r5-048

08:09:35     INFO -  REFTEST TEST-START | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/dom/plugins/test/crashtests/752340.html
08:09:35     INFO -  REFTEST TEST-LOAD | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/dom/plugins/test/crashtests/752340.html | 2400 / 2485 (96%)
08:09:35     INFO -  2013-06-25 08:09:35.298 firefox-bin[1092:9707] invalid context
08:09:35     INFO -  2013-06-25 08:09:35.300 firefox-bin[1092:9707] invalid context
08:09:35     INFO -  2013-06-25 08:09:35.301 firefox-bin[1092:9707] invalid context
08:09:44  WARNING -  TEST-UNEXPECTED-FAIL | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/dom/plugins/test/crashtests/752340.html | Exited with code 1 during test run
08:09:44     INFO -  INFO | automation.py | Application ran for: 0:04:37.864573
08:09:44     INFO -  INFO | zombiecheck | Reading PID log: /var/folders/0x/4q6p61sd48v3k3ndq9mwpp3400000w/T/tmpuIyWrdpidlog
08:09:44     INFO -  mozcrash INFO | Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1372167785/firefox-25.0a1.en-US.mac.crashreporter-symbols.zip
08:09:44     INFO -  Downloading symbols from: http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-macosx64/1372167785/firefox-25.0a1.en-US.mac.crashreporter-symbols.zip
08:10:27  WARNING -  PROCESS-CRASH | file:///builds/slave/talos-slave/test/build/tests/reftest/tests/dom/plugins/test/crashtests/752340.html | application crashed [@ OpenGL + 0x3317]
08:10:27     INFO -  Crash dump filename: /var/folders/0x/4q6p61sd48v3k3ndq9mwpp3400000w/T/tmpTP0nyc/minidumps/FD37963C-505C-4FC2-844A-B5DBDA1BE197.dmp
08:10:27     INFO -  Operating system: Mac OS X
08:10:27     INFO -                    10.8.0 12A269
08:10:27     INFO -  CPU: amd64
08:10:27     INFO -       family 6 model 42 stepping 7
08:10:27     INFO -       8 CPUs
08:10:27     INFO -  Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
08:10:27     INFO -  Crash address: 0x4dcfdf00
08:10:27     INFO -  Thread 17 (crashed)
08:10:27     INFO -   0  OpenGL + 0x3317
08:10:27     INFO -      rbx = 0x000000014dcfc000   r12 = 0x000000011e3e5400
08:10:27     INFO -      r13 = 0x000000010eded500   r14 = 0x000000010d580948
08:10:27     INFO -      r15 = 0x000000014dcfc000   rip = 0x00007fff966e3317
08:10:27     INFO -      rsp = 0x000000010d5808f0   rbp = 0x000000010d580900
08:10:27     INFO -      Found by: given as instruction pointer in context
08:10:27     INFO -   1  OpenGL + 0xc269
08:10:27     INFO -      rip = 0x00007fff966ec26a   rsp = 0x000000010d580910
08:10:27     INFO -      rbp = 0x000000010d580930
08:10:27     INFO -      Found by: stack scanning
08:10:27     INFO -   2  AppKit + 0x68ae0
08:10:27     INFO -      rip = 0x00007fff959c8ae1   rsp = 0x000000010d580940
08:10:27     INFO -      rbp = 0x000000010d580950
08:10:27     INFO -      Found by: stack scanning
08:10:27     INFO -   3  XUL!mozilla::gl::GLContextCGL::MakeCurrentImpl(bool) [GLContextProviderCGL.mm:2c9674fbea6a : 133 + 0x13]
08:10:27     INFO -      rip = 0x0000000102ac5d41   rsp = 0x000000010d580960
08:10:27     INFO -      rbp = 0x000000010d580980
08:10:27     INFO -      Found by: stack scanning
08:10:27     INFO -   4  XUL!mozilla::layers::CompositorOGL::MakeCurrent(unsigned int) [GLContext.h:2c9674fbea6a : 189 + 0x2]
08:10:27     INFO -      rbx = 0x0000000000000320   r14 = 0x00000000000003e8
08:10:27     INFO -      rip = 0x0000000102a6cb87   rsp = 0x000000010d580990
08:10:27     INFO -      rbp = 0x000000010d580990
08:10:27     INFO -      Found by: call frame info
08:10:27     INFO -   5  XUL!mozilla::layers::CompositorOGL::BeginFrame(mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const*, gfxMatrix const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits> const&, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits>*, mozilla::gfx::RectTyped<mozilla::gfx::UnknownUnits>*) [CompositorOGL.cpp:2c9674fbea6a : 832 + 0xb]
08:10:27     INFO -      rbx = 0x0000000000000320   r14 = 0x00000000000003e8
08:10:27     INFO -      rip = 0x0000000102a6a631   rsp = 0x000000010d5809a0
08:10:27     INFO -      rbp = 0x000000010d580a40
08:10:27     INFO -      Found by: call frame info
Very similar to bug 863313.
Crash Signature: [@ OpenGL@0x3317]
See Also: → 887360, 887361
https://tbpl.mozilla.org/php/getParsedLog.php?id=24795766&tree=Fx-Team
Summary: Intermittent dom/plugins/test/crashtests/752340.html | Exited with code 1 during test run | application crashed [@ OpenGL + 0x3317] → Intermittent 752340.html,browser_social_errorPage.js | Exited with code 1 during test run | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08]
https://tbpl.mozilla.org/php/getParsedLog.php?id=24878784&tree=Mozilla-Inbound
Summary: Intermittent 752340.html,browser_social_errorPage.js | Exited with code 1 during test run | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08] → Intermittent 752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js | Exited with code 1 during test run | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62]
Duplicate of this bug: 899981
Summary: Intermittent 752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js | Exited with code 1 during test run | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62] → Intermittent 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js | Exited with code 1 during test run | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62]
Assignee: nobody → milan
https://tbpl.mozilla.org/php/getParsedLog.php?id=26507267&tree=Fx-Team
Summary: Intermittent 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js | Exited with code 1 during test run | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62] → Intermittent 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js,test_nested_eventloop.html | Exited with code 1 during test run | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62]
Assignee: milan → gabadie
I tried to find similarities between logs, and here is the result:

------------- Mac OS X 10.7.2:
 - GPU: NVIDIA GeForce 320M
 - CPU: Intel core 2 duo
 - crash triggered by /tests/docshell/test/navigation/test_sessionhistory.html
     https://tbpl.mozilla.org/php/getParsedLog.php?id=25326294&full=1&branch=mozilla-aurora#error3
 - crash in /tests/dom/tests/mochitest/bugs/test_bug346659.html
     https://tbpl.mozilla.org/php/getParsedLog.php?id=25676472&full=1&branch=mozilla-inbound#error3
 - crash in file:///Users/cltbld/talos-slave/test/build/tests/reftest/tests/parser/htmlparser/tests/crashtests/30885-1.html
     https://tbpl.mozilla.org/php/getParsedLog.php?id=25916400&full=1&branch=mozilla-inbound#error1
     https://tbpl.mozilla.org/php/getParsedLog.php?id=25692465&full=1&branch=mozilla-inbound#error3

------------- Mac OS X 10.8.0:
 - GPU: Intel HD Graphics 3000
 - CPU: Intel i7
 - crash in /tests/content/media/webspeech/recognition/test/test_nested_eventloop.html
     stack: mozilla::layers::CompositorOGL::BeginFrame
        https://tbpl.mozilla.org/php/getParsedLog.php?id=26491296&full=1&branch=b2g-inbound#error1
        https://tbpl.mozilla.org/php/getParsedLog.php?id=26507267&full=1&branch=fx-team#error1
        https://tbpl.mozilla.org/php/getParsedLog.php?id=25781733&full=1&branch=fx-team#error1
     stack: XUL!mozilla::gl::BasicTextureImage::~BasicTextureImage()
        https://tbpl.mozilla.org/php/getParsedLog.php?id=26500503&full=1&branch=mozilla-inbound#error1

The interesting thing is that only /tests/content/media/webspeech/recognition/test/test_nested_eventloop.html triggers a crash in 10.8.

But, I was not able to reproduce any of those crashes locally.
Summary: Intermittent 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js,test_nested_eventloop.html | Exited with code 1 during test run | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62] → Intermittent 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js,test_nested_eventloop.html | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62]
https://tbpl.mozilla.org/php/getParsedLog.php?id=26859165&tree=Mozilla-Central
Summary: Intermittent 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js,test_nested_eventloop.html | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62] → Intermittent 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js,test_nested_eventloop.html,test_bug509244.html | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62]
Assignee: guillaume.abadie → nobody
Looks like this needs an owner again....
Flags: needinfo?(milan)
We do get an "invalid context" and "invalid drawable" messages around the failing test, but that happens even when the test doesn't fail.
Milan, any luck with this?
Summary: Intermittent 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js,test_nested_eventloop.html,test_bug509244.html | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62] → Intermittent 30885-1.html,752340.html,browser_social_errorPage.js,browser_tabview_bug595930.js,test_nested_eventloop.html,test_bug509244.html,test_showModalDialog.html | application crashed [@ OpenGL + 0x3317][@ OpenGL + 0x7e08][@ OpenGL + 0x2a62]