Last Comment Bug 887045 - Private windows opened after normal windows appear in recently closed window list
: Private windows opened after normal windows appear in recently closed window ...
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Session Restore (show other bugs)
: unspecified
: All All
-- normal (vote)
: seamonkey2.22
Assigned To: neil@parkwaycc.co.uk
:
:
Mentors:
Depends on:
Blocks: 460895
  Show dependency treegraph
 
Reported: 2013-06-25 16:19 PDT by neil@parkwaycc.co.uk
Modified: 2013-07-22 11:48 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
wontfix
fixed
fixed
fixed


Attachments
Proposed patch (1.72 KB, patch)
2013-06-25 16:24 PDT, neil@parkwaycc.co.uk
iann_bugzilla: review+
philip.chee: feedback+
iann_bugzilla: approval‑comm‑aurora+
bugspam.Callek: approval‑comm‑beta+
Details | Diff | Splinter Review

Description User image neil@parkwaycc.co.uk 2013-06-25 16:19:20 PDT
Steps to reproduce problem:
1. Start with a private window
2. Open a browser window
3. Close the private window
4. Note the recently closed window list
5. Open another private window
6. Close the private window
7. Note the recently closed window list

This happens because there are two ways for Session Store to notice a window, the first is by the window calling init, and the second is by Session Store looking for browser windows once it's been initialised. Session Store tries to avoid finding non-browser windows but this doesn't seem to work as I expect, there's probably a race condition somewhere (I think it manages to add its onload handler first).
Comment 1 User image neil@parkwaycc.co.uk 2013-06-25 16:24:06 PDT
Created attachment 767488 [details] [diff] [review]
Proposed patch
Comment 2 User image Philip Chee 2013-06-29 08:17:27 PDT
Comment on attachment 767488 [details] [diff] [review]
Proposed patch

OK this is WFM so f=me.
Comment 3 User image Ian Neal 2013-07-02 05:35:27 PDT
Comment on attachment 767488 [details] [diff] [review]
Proposed patch

r=me
Comment 4 User image neil@parkwaycc.co.uk 2013-07-10 13:55:49 PDT
Pushed comm-central changeset 2beded163a35.
Comment 5 User image neil@parkwaycc.co.uk 2013-07-10 14:25:16 PDT
Comment on attachment 767488 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
User impact if declined: Privacy leak
Risk to taking this patch (and alternatives if risky): Low
String changes made by this patch: None
Comment 6 User image neil@parkwaycc.co.uk 2013-07-21 14:55:00 PDT
http://hg.mozilla.org/releases/comm-aurora/rev/d595ece2c097
Comment 7 User image Justin Wood (:Callek) [away until Feb 27] 2013-07-21 21:05:26 PDT
Comment on attachment 767488 [details] [diff] [review]
Proposed patch

Review of attachment 767488 [details] [diff] [review]:
-----------------------------------------------------------------

a-beta=me, a-CLOSED_TREE=me
Comment 8 User image neil@parkwaycc.co.uk 2013-07-22 11:48:05 PDT
http://hg.mozilla.org/releases/comm-beta/rev/ad06842957a1

Note You need to log in before you can comment on or make changes to this bug.