Saving File window prevents access to other windows in Fizzilla

VERIFIED FIXED in mozilla0.9.3

Status

()

--
major
VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: mrfgifford, Assigned: mikepinkerton)

Tracking

Trunk
mozilla0.9.3
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: OSX++, PDT+)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.1+) Gecko/
BuildID:    2001061314

After completing any Save File dialog (after selecting Save As, Save Link As,
etc. from a menu), a Saving File window appears.  Until the file has completed
downloading, I am unable to access any other Mozilla windows.  Attempting to
click on them results in an alert sound.

Reproducible: Always
Steps to Reproduce:
1. Find a file that will take several seconds down download.  While this is not
necessary, it allows more time for confirming the problem.
2. Select Save As from the File menu or a contextual menu.
3. Select a location to save the file in the Save File dialog and click the Save
button.

Actual Results:  Once the Saving File window appears, it is locked as the active
Mozilla window until the download is complete.

Expected Results:  The Saving File window should act as any other window.  It
should allow the user to make other windows active.  It should also be minimizable.
Confirmed. This might be a duplicate of bug 83643. At least this is a related issue.
Status: UNCONFIRMED → NEW
Ever confirmed: true
--> Toolkit
Assignee: asa → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: doronr → aegis
*** Bug 88520 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

17 years ago
danm, why would this mozilla window be modal?
Assignee: trudelle → danm
Target Milestone: --- → mozilla1.0

Comment 5

17 years ago
Isn't this related or dependant on bug #73812 After all a save dialog shold
appear as a "sheet"
(Assignee)

Comment 6

17 years ago
we're not talking about the save-file dialog, but the progress window that 
appears showing the download. it's title happens to be 'save file'.

Comment 7

17 years ago
I am seeing this bug as well on the 2001070318 build of Fizilla.  The download
progress window is modal and will not allow access to any other Mozilla window.
 Tested on Mac OS X 10.0.4
Problem still pressent in Mozilla 0.9.2 on MacOS X, works fine on MacOS 9.1
(Assignee)

Comment 9

17 years ago
damn is on vacation, over to dagley for a looksee. beta-stopper?
Assignee: danm → sdagley
Whiteboard: OSX+

Comment 10

17 years ago
Accepting bug.  Not necessarily a beta stopper but annoying none the less.  
Prolly just need to change the window proc so OS X doesn't think it's a modal 
dialog.
Status: NEW → ASSIGNED

Comment 11

17 years ago
*** Bug 90679 has been marked as a duplicate of this bug. ***

Updated

17 years ago
URL: any
Severity: normal → major
(Assignee)

Comment 12

17 years ago
Created attachment 42307 [details] [diff] [review]
[patch] don't use carbon's modality, use our own
(Assignee)

Comment 13

17 years ago
i have a fix for this, scc has sr'd it. i just need an r to land on trunk and 
branch. this also fixes 85111, the pinstripe border around all dialogs.
Assignee: sdagley → pinkerton
Status: ASSIGNED → NEW
Whiteboard: OSX+ → OSX++, PDT+
(Assignee)

Updated

17 years ago
Blocks: 85111
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla0.9.3

Comment 14

17 years ago
nice work, patch looks good, r=pchen
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: OSX++, PDT+ → OSX++, PDT+, waiting for tree to open

Comment 15

17 years ago
nice indeedy, I'll add an r= of my own
(Assignee)

Comment 16

17 years ago
checked in on branch and trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Whiteboard: OSX++, PDT+, waiting for tree to open → OSX++, PDT+

Comment 17

17 years ago
verified on OSX:
2001-07-17 0.9.2 branch.  Able to minimize the save as dlg, switch to another
application window within the build, and switch to the desktop (outside of our
build).

mark vtrunk for trunk verification still needed. Asa, can you verify this on
trunk since you run the fizzilla builds regularly?  Thanks.
Keywords: vtrunk

Comment 18

17 years ago
I'll verify as soon as we start getting OS X trunk builds. 

Comment 19

17 years ago
Is the patch in the trunk yet? I'm seeing the bug on build 20001070515. If not,
any idea when?
(Assignee)

Comment 20

17 years ago
it went onto the trunk long after 7/5, so i'm not surprised you're seeing this in 
that build.

Comment 21

17 years ago
Verified on the trunk with Fizzilla build 2001080613.  I started a large
download and was able to access and maninpulate all other open Mozilla windows.
 I was able to minimize the and restore the download progress dialog.  Marking
Verfied and removing vtrunk keyword
Status: RESOLVED → VERIFIED
Keywords: vtrunk
You need to log in before you can comment on or make changes to this bug.