Closed Bug 887114 Opened 8 years ago Closed 8 years ago

Update Bugzilla/DB.pm to use SQL_CACHE for bz_schema table access

Categories

(bugzilla.mozilla.org :: General, defect)

Production
x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: dkl, Assigned: dkl)

References

Details

Attachments

(1 file)

The bz_schema table changes infrequently (whenever schema changes happen) and is load quite a bit because of bz_column_info in Bugzilla::Object. We would benefit from having SQL_CACHE added to the SELECT that loads the schema data. Sheeri has said that query caching is off be default on our DB servers so SQL_CACHE will override and cache those particular queries.

Attaching patch.

dkl
Attachment #767575 - Flags: review?(glob)
this won't do anything because query_cache_type is OFF on production.
Assignee: nobody → dkl
Depends on: 887126
Yes, we wanted to test in stage first. I had misinformation about dev that I've now updated; all dev/stage/prod databases have query caching on. Please submit the patch and once tests are running I can confirm that dev is in fact caching the proper query (we can see how many queries are in the query cache, and how many hits the query cache is getting). Once that's done we can repeat for stage and prod.
Comment on attachment 767575 [details] [diff] [review]
Patch to use SQL_CACHE when loading bz_schema (v1)

r=glob
Attachment #767575 - Flags: review?(glob) → review+
committed to get this onto stage while sheeri was around to test.

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified Bugzilla/DB.pm
Committed revision 8857.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.