Last Comment Bug 887236 - prefix the current events in workers with "Worker"
: prefix the current events in workers with "Worker"
Status: RESOLVED FIXED
: dev-doc-complete, site-compat
Product: Core
Classification: Components
Component: DOM: Workers (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla25
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on: 921485
Blocks: 887239
  Show dependency treegraph
 
Reported: 2013-06-26 05:54 PDT by Olli Pettay [:smaug]
Modified: 2013-11-06 05:33 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (3.83 KB, patch)
2013-06-26 07:08 PDT, Olli Pettay [:smaug]
bent.mozilla: review+
Details | Diff | Splinter Review

Description Olli Pettay [:smaug] 2013-06-26 05:54:33 PDT
...the same way as what we have in the main thread.
That way we can start using the real DOM events in workers without any hacks in them.
Comment 1 Olli Pettay [:smaug] 2013-06-26 07:08:25 PDT
Created attachment 767736 [details] [diff] [review]
patch

https://tbpl.mozilla.org/?tree=Try&rev=b81f1f6c9fc4

This is regression risky, but I don't know how else to deal with this.
Eventually all the events should be DOM events ofc.
Comment 2 Jonas Sicking (:sicking) PTO Until July 5th 2013-06-26 07:21:22 PDT
I wouldn't worry too much about this breaking things. I don't think these interfaceobjects are used terribly much. Though it would be good to land this early in a cycle and then hope that a lot of the followup patches to use more xpcom Events in workers can land in the same cycle.
Comment 4 Ryan VanderMeulen [:RyanVM] 2013-07-08 13:26:03 PDT
https://hg.mozilla.org/mozilla-central/rev/794da9907814
Comment 6 Jean-Yves Perrier [:teoli] 2013-07-15 00:59:18 PDT
I switched back the doc flag as there much more doc needed for this bug: we need to actually document WorkerEvent and co :-)

BTW, I wasn't able to find the spec where these interfaces are specified. Anybody knows about it?

Thanks in advance.
Comment 7 :Ms2ger 2013-07-15 01:50:49 PDT
We shouldn't document the Worker* variants, IMO. They're broken versions of the Event interfaces, only exposed to workers; they're being renamed because we're going to implement the correct main-thread implementations to workers.
Comment 8 Olli Pettay [:smaug] 2013-07-15 12:06:13 PDT
There are Worker* events also in the main thread, in case events are dispatched to main thread Worker.
But yes, all the Worker* events are just temporary and we're trying to get rid of them asap.
Comment 9 Jean-Yves Perrier [:teoli] 2013-07-16 00:17:07 PDT
So I switch back to dev-doc-complete :-) Thanks for the explanation!
Comment 10 Masatoshi Kimura [:emk] 2013-07-16 21:26:15 PDT
I think the site-compat doc should explain that the change is temporary.
Comment 11 Kohei Yoshino [:kohei] 2013-07-27 10:44:33 PDT
Fixed the description in the compatibility doc.
Comment 12 Florian Bender 2013-09-04 11:04:01 PDT
Can you please point me to the bug that undoes the change?
Comment 13 Masatoshi Kimura [:emk] 2013-09-27 07:15:56 PDT
Filed bug 921485.
Comment 14 Masatoshi Kimura [:emk] 2013-11-05 20:04:39 PST
The temporary "Worker" prefix was removed again by bug 928312.
Comment 15 Kohei Yoshino [:kohei] 2013-11-06 05:33:39 PST
(In reply to Masatoshi Kimura [:emk] from comment #14)
> The temporary "Worker" prefix was removed again by bug 928312.

OK, will add a note to the 28 compat doc :)

Note You need to log in before you can comment on or make changes to this bug.