Closed Bug 887239 Opened 9 years ago Closed 9 years ago

Make normal DOM events to work also in workers

Categories

(Core :: DOM: Workers, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 853893

People

(Reporter: smaug, Unassigned)

References

Details

Currently workers have some odd JS API implemented events.
Now that DOM events use webidl, and nsDOMEventTargetHelper is also thread-agnostic, we should start using DOM events in workers.
Depends on: 887241
So for what it's worth, we could fix bug 862627 just for worker bindings pretty easily.  Let me know if we want to do that so that workers are not blocked on the mainthread window-closing mess, ok?
Flags: needinfo?(bugs)
That might be good. That and the atom handling are the blockers-without-patches atm.
Flags: needinfo?(bugs)
Hmm.  I guess we need a general bug about making WebIDL callbacks work in workers.  :(  Right now they're very much tied to xpconnect for things like getting the JSContext.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853893
No longer depends on: 862627
No longer depends on: 887241
You need to log in before you can comment on or make changes to this bug.