minimize/tear-off/close icons of chat windows are pixelated on a retina screen

VERIFIED FIXED in Firefox 24

Status

defect
--
minor
VERIFIED FIXED
6 years ago
6 months ago

People

(Reporter: florian, Assigned: florian)

Tracking

Trunk
Firefox 25
x86
macOS

Firefox Tracking Flags

(firefox23 unaffected, firefox24 fixed, firefox25 verified)

Details

Attachments

(5 attachments, 3 obsolete attachments)

My guess is that the file browser/themes/osx/social/chat-icons.png needs an @2x.png version.
Posted image Screenshot
Boriss, can you get us the @2 icons for the chat window controls?
Assignee: nobody → jboriss
Keywords: uiwanted
@Boriss ping
Posted image Screenshot with attachment 776277 (obsolete) —
Attachment 776277 [details] used on the left side of the screenshot, and a current nightly on the right side to compare.
Posted patch Patch (obsolete) — Splinter Review
Patch used to make the screenshot in attachment 776295 [details].
On Florian's suggestion, redid icons to be consistent with OSX tab controls, suspect it'll look more visually consistent
Posted patch Patch v2Splinter Review
This uses 16x16px (and 32x32px for retina) icons to be more consistent with the camera icon, and tab icons.
Assignee: jboriss → florian
Attachment #776277 - Attachment is obsolete: true
Attachment #776295 - Attachment is obsolete: true
Attachment #776297 - Attachment is obsolete: true
Attachment #780384 - Flags: review?(mixedpuppy)
Posted image Screenshot
With attachment 780384 [details] [diff] [review] on the left side; with a current nightly on the right side.
Keywords: uiwanted
Comment on attachment 780384 [details] [diff] [review]
Patch v2

looks ok to me, but get a reviewer to look
Attachment #780384 - Flags: review?(mixedpuppy) → review?(mconley)
Comment on attachment 780384 [details] [diff] [review]
Patch v2

Review of attachment 780384 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me.
Attachment #780384 - Flags: review?(mconley) → review+
Comment on attachment 780384 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 880911
User impact if declined: ugly icons on retina display
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #780384 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/02e569264881
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Attachment #780384 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Needs a branch-specific patch for uplift.
Flags: needinfo?(florian)
Posted patch Patch V2 Fx24Splinter Review
branch patch
Flags: needinfo?(florian)
Matt, can you please verify this is fixed in Firefox 25?
QA Contact: mwobensmith
Confirmed problem on FF25, 2013-06-26.
Verified fixed on FF25, 2013-10-21.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.