If the region is Durango and language is set to polish some words will still appear in english during purchase flow

RESOLVED FIXED in 2013-07-11

Status

Marketplace
Payments/Refunds
P1
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Vikas Nanda, Assigned: Keir Kettle)

Tracking

2013-07-11
Other
Gonk (Firefox OS)
Points:
---
Bug Flags:
affects-durango +

Details

Attachments

(15 attachments)

(Reporter)

Description

5 years ago
Created attachment 767827 [details]
screenshot 1

Steps to reproduce:

1. Change the region to Durango and language is set to Polish
2. Search for a paid app and select buy. 
3. Notice that some words appear in English during the purchase flow. 

Expected behaviour

All language should be displayed in Polish.

Observed behaviour

Some words appear in English
(Reporter)

Comment 1

5 years ago
Created attachment 767828 [details]
screenshot2
(Reporter)

Updated

5 years ago
Summary: If the region is Durango and language is set to polish some words will still appear in english → If the region is Durango and language is set to polish some words will still appear in english during purchase flow
(Reporter)

Comment 2

5 years ago
Created attachment 767829 [details]
screenshot 3

Updated

5 years ago
Assignee: nobody → clouserw
(Reporter)

Comment 3

5 years ago
Created attachment 767830 [details]
screenshot4
(Reporter)

Comment 4

5 years ago
Created attachment 767831 [details]
screenshot5

Updated

5 years ago
Priority: -- → P3
Strings are extracted in https://github.com/mozilla/webpay/commit/2b9495d7a9f43c7126bbade4bc874e7609cf111a .  Since the strings are out, I'll close this bug.  This won't actually be verifiable until localizers update the .po files.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Priority: P3 → --
Resolution: --- → FIXED
Target Milestone: --- → 2013-07-04

Comment 6

4 years ago
Created attachment 770452 [details]
UI appears in English instead of Polish

Comment 7

4 years ago
Created attachment 770454 [details]
UI appears in English instead of Polish

Comment 8

4 years ago
Created attachment 770456 [details]
UI appears in English instead of Polish

Comment 9

4 years ago
The screen where the user enters the Pin number appears in English and also the screen that appears after that has the text "The amount will be charged to your T-Mobile account. Credit card payment not supported for this app" also appears in English. If the user selects the link "Oplata za sms-y i dane wg stawek operatora" the screen titled "Msg & Data Rates May Apply" is also in English.
(Reporter)

Comment 10

4 years ago
New screenshots added showing this issue still occurs
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The "forgot your pin?" string is in webpay, but I don't see the other strings in the code at all.  Are those ours or bangos?

For the record, I don't know why "Forgot your pin?" wouldn't be showing up translated.
Flags: needinfo?(wraithan)
Target Milestone: 2013-07-04 → 2013-07-11
This works fine in local dev. 

Checking on unagi and desktop and the accept-language headers are being sent.

Interestingly whereas in local dev I can change the lang when modifying the query string param e.g "lang=pl" this doesn't work on stage either.

Updated

4 years ago
Flags: affects-durango+
The open bug about PIN screens (Mozilla's side) not being translated is here: bug 885551

Updated

4 years ago
Priority: -- → P1
Polish is 100% on Mozilla side
Assignee: clouserw → keir
Flags: needinfo?(wraithan)

Comment 15

4 years ago
Created attachment 773596 [details]
UI is in English

Comment 16

4 years ago
Created attachment 773597 [details]
UI is in English_1

Comment 17

4 years ago
Created attachment 773598 [details]
UI is in English_3

Comment 18

4 years ago
Created attachment 773599 [details]
UI is in English_2

Comment 19

4 years ago
Created attachment 773600 [details]
UI is in English_4

Comment 20

4 years ago
Created attachment 773602 [details]
UI is in English_5
(Reporter)

Comment 21

4 years ago
Created attachment 773603 [details]
ezboot log

Comment 22

4 years ago
Time: 11:55pm CEST
Phone number: 787 633 833
Pricetier: 10
Credit card: n/a
if there are more bugs, please file a separate bug
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.