Closed Bug 887331 Opened 11 years ago Closed 11 years ago

If the region is Durango and language is set to polish some words will still appear in english during purchase flow

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P1)

Other
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED
2013-07-11

People

(Reporter: vikas.nanda, Assigned: keir)

References

Details

Attachments

(15 files)

Attached image screenshot 1
Steps to reproduce:

1. Change the region to Durango and language is set to Polish
2. Search for a paid app and select buy. 
3. Notice that some words appear in English during the purchase flow. 

Expected behaviour

All language should be displayed in Polish.

Observed behaviour

Some words appear in English
Attached image screenshot2
Summary: If the region is Durango and language is set to polish some words will still appear in english → If the region is Durango and language is set to polish some words will still appear in english during purchase flow
Attached image screenshot 3
Assignee: nobody → clouserw
Attached image screenshot4
Attached image screenshot5
Priority: -- → P3
Strings are extracted in https://github.com/mozilla/webpay/commit/2b9495d7a9f43c7126bbade4bc874e7609cf111a .  Since the strings are out, I'll close this bug.  This won't actually be verifiable until localizers update the .po files.
Status: NEW → RESOLVED
Closed: 11 years ago
Priority: P3 → --
Resolution: --- → FIXED
Target Milestone: --- → 2013-07-04
The screen where the user enters the Pin number appears in English and also the screen that appears after that has the text "The amount will be charged to your T-Mobile account. Credit card payment not supported for this app" also appears in English. If the user selects the link "Oplata za sms-y i dane wg stawek operatora" the screen titled "Msg & Data Rates May Apply" is also in English.
New screenshots added showing this issue still occurs
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The "forgot your pin?" string is in webpay, but I don't see the other strings in the code at all.  Are those ours or bangos?

For the record, I don't know why "Forgot your pin?" wouldn't be showing up translated.
Flags: needinfo?(wraithan)
Target Milestone: 2013-07-04 → 2013-07-11
This works fine in local dev. 

Checking on unagi and desktop and the accept-language headers are being sent.

Interestingly whereas in local dev I can change the lang when modifying the query string param e.g "lang=pl" this doesn't work on stage either.
Flags: affects-durango+
The open bug about PIN screens (Mozilla's side) not being translated is here: bug 885551
Priority: -- → P1
Polish is 100% on Mozilla side
Assignee: clouserw → keir
Flags: needinfo?(wraithan)
Attached image UI is in English
Attached image UI is in English_1
Attached image UI is in English_3
Attached image UI is in English_2
Attached image UI is in English_4
Attached image UI is in English_5
Attached file ezboot log
Time: 11:55pm CEST
Phone number: 787 633 833
Pricetier: 10
Credit card: n/a
if there are more bugs, please file a separate bug
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: