Need proper error message for users who try to save a remix but aren't signed in

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Jacob, Assigned: thecount)

Tracking

Details

(Reporter)

Description

5 years ago
STR:

- Go to https://popcorn.webmaker.org/editor/55591/remix

- Make a change and hit save


Expected Result:

A dialog box that says "You can't save because you're not signed in...please take a second to sign up and claim your own webmaker domain..."


Actual Result:

Standard error message that doesn't explain cause of the problem:

There was a problem saving your project, so it was backed up to your browser's storage (i.e., you can close or reload this page and it will be recovered). Please try again.
(Assignee)

Comment 1

5 years ago
I think we used to disable that button until you're signed in.

See bug 882688

Thanks for bringing this back into my attention.
(Assignee)

Comment 2

5 years ago
I still think there is some disconnect between the save, rename, and log/sign in buttons.

At the very least a tooltip over the save buttong (like the one we have for title).

At the most, move the buttons to be in the same area, to draw attention to what is needed next.

Other ideas?
Assignee: nobody → scott
(Assignee)

Updated

5 years ago
Duplicate of this bug: 897451
(Assignee)

Comment 4

5 years ago
A tooltip was recently added for the save button if not logged in.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.