Closed Bug 887680 Opened 7 years ago Closed 7 years ago

[User Story] Create a conf call with upto 5 participants

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P1)

x86
macOS
defect

Tracking

(blocking-b2g:koi+)

RESOLVED FIXED
blocking-b2g koi+

People

(Reporter: wmathanaraj, Assigned: rik)

References

Details

(Keywords: feature, Whiteboard: [MOZ][UCID:Comms9, FT:comms, KOI:P1], [u=commsapps-user c=dialer p=0][Sprint 2][Status: UX: initla draft provided, Gecko: close to completion, Gaia: Starting Gaia implementation])

Attachments

(4 files)

User Story

As a user I expect to join up to 5 users into a conference call by making MO or MT calls. I expect to be able to put the conference call on hold while making or receiving a new call.
As a user, if I have 5 people on a conference call, I have to drop the conference call to be able to make an emergency call. If I dont have 5 people on a conference call, I want to be able to put the conference call on hold and make an emergency call when needed.


Preconditions:

* dialer app is open
* network supports upto 5 people on a conf call

Acceptance Criteria:

* user is informed if more than 5 people are attempted to be joined into a conf call of the max limit of 5
* user is informed that currently there is a conference call taking place on the dialer screen
* user is informed of any error situation in a comprehend-able message
Support for conference calls is being implemented in bug 772765.
Depends on: 772765
Depends on: 889255
Whiteboard: [ucid:Comms9] → [ucid:Comms9], [u=commsapps-user c=dialer p=0]
listed as must have in v1.2 for COMM team. koi+
blocking-b2g: koi? → koi+
Flags: in-moztrap?
MozTrap #9054, #9055, #9056
Flags: in-moztrap? → in-moztrap+
(In reply to Al Tsai [:atsai] from comment #3)
> MozTrap #9054, #9055, #9056

MozTrap #9052, #9053, #9054
Sorry, my bad.
Whiteboard: [ucid:Comms9], [u=commsapps-user c=dialer p=0] → [ucid:Comms9 KOI:P1], [u=commsapps-user c=dialer p=0]
Blocks: 890912
Assignee: nobody → jcheng
Whiteboard: [ucid:Comms9 KOI:P1], [u=commsapps-user c=dialer p=0] → [UCID:Comms9, FT:comms, KOI:P1], [u=commsapps-user c=dialer p=0]
Assignee: jcheng → nobody
Whiteboard: [UCID:Comms9, FT:comms, KOI:P1], [u=commsapps-user c=dialer p=0] → [MOZ][UCID:Comms9, FT:comms, KOI:P1], [u=commsapps-user c=dialer p=0]
Whiteboard: [MOZ][UCID:Comms9, FT:comms, KOI:P1], [u=commsapps-user c=dialer p=0] → [MOZ][UCID:Comms9, FT:comms, KOI:P1], [u=commsapps-user c=dialer p=0][Sprint 1][Status: need UX, working on gecko support]
Whiteboard: [MOZ][UCID:Comms9, FT:comms, KOI:P1], [u=commsapps-user c=dialer p=0][Sprint 1][Status: need UX, working on gecko support] → [MOZ][UCID:Comms9, FT:comms, KOI:P1], [u=commsapps-user c=dialer p=0][Sprint 2][Status: UX: initla draft provided, Gecko: close to completion, Gaia: Starting Gaia implementation]
Assignee: nobody → anthony
Depends on: 902840
Depends on: 891763
Depends on: 881194
Blocks: 881194
No longer depends on: 881194
Please find all visual designs in the following folder: https://mozilla.box.com/s/o79mkjw8oetqhu6uu26u

If you have any question about them lease needinfo me.

Thanks! Victoria
Flags: needinfo?(vpg)
Flags: needinfo?(vpg)
Could you put those in a public folder? I can't access them.
Flags: needinfo?(vpg)
Flags: needinfo?(vpg)
I've attached the screens related to this bug, but you should also have access to the box link now. If not, this is being sorted out today. Thanks!
Victoria, can you upload the assets for the merge button?
Rik's patch should be ready today so hopefully we can land this with the right asset.
Flags: needinfo?(vpg)
Flags: needinfo?(vpg)
Attachment #804413 - Flags: review?(etienne)
Comment on attachment 804413 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/12217

r **** plus :)
Attachment #804413 - Flags: review?(etienne) → review+
https://github.com/mozilla-b2g/gaia/commit/caa1651eed73fdc1fb049490393eb5b69e4848ac
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 910075
You need to log in before you can comment on or make changes to this bug.