Closed Bug 888099 Opened 6 years ago Closed 6 years ago

gaia perf tests broken: [Exception... \"Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]

Categories

(Firefox OS Graveyard :: Gaia, defect, P1, critical)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 915156
1.2 C5(Nov22)

People

(Reporter: jgriffin, Assigned: hub)

References

Details

(Keywords: perf, Whiteboard: [c=automation p= s= u=])

Attachments

(1 file, 3 obsolete files)

All of the gaia perf tests (run via make test-perf) are failing with the following exception:

"stack": "[Exception... \"Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]\"  nsresult: \"0x8000ffff (NS_ERROR_UNEXPECTED)\"  location: \"JS frame :: jar:file:///var/jenkins/workspace/b2g.inari.comril.gaia.master.mozperftest/gaia/xulrunner-sdk/bin/omni.ja!/components/TCPSocket.js :: ts_initWindowless :: line 294\"  data: no]",

This is happening with gaia master branch.
Severity: normal → critical
Keywords: perf
Priority: -- → P1
Whiteboard: [c= ]
It tries to

    return Services.prefs.getBoolPref("dom.mozTCPSocket.enabled");

Likely the pref is missing, hence the exception.
Strange, I just tested with master today and they appear to be working for me. 

I do notice that message though when "remote debugging" is enabled from settings. I generally need to unplug the phone, disable remote debugging, then reboot the phone for it to work.
It is not impossible that it is a problem with the profile.
Assignee: nobody → joey
Joey, this needs a "review?" flag if you expect some to review and approve your patch.
Status: NEW → ASSIGNED
Flags: needinfo?(jgriffin)
Comment on attachment 770815 [details] [diff] [review]
move HOST_CPPSRCS to mozbuild (file batch #1).

Flagging a build peer for review.
Attachment #770815 - Flags: review?(ted)
Comment on attachment 770815 [details] [diff] [review]
move HOST_CPPSRCS to mozbuild (file batch #1).

I assume this is on the wrong bug?
Seems likely, :joey, which bug is this intended to address?
Flags: needinfo?(jgriffin) → needinfo?(joey)
Attachment #770815 - Attachment is obsolete: true
Attachment #770815 - Flags: review?(ted)
Attachment #772248 - Attachment is obsolete: true
:joey, please check the bug # in your patch, it seems wrong
(In reply to Mike Lee [:mlee] from comment #5)
> Joey, this needs a "review?" flag if you expect some to review and approve
> your patch.

Whups to be deleted, bad bug number in the comments with a bzexport push.
Flags: needinfo?(joey)
Comment on attachment 772250 [details] [diff] [review]
move HOST_CPPSRCS to mozbuild (file batch #1).

Obsolete stray patch upload.
Attachment #772250 - Attachment is obsolete: true
Assignee: joey → nobody
Attached file perf-output.txt
So, this is no longer crashing, but it's still not running. It appears to be failing down inside the marionette.js framework now based on the stack traces coming out of it. James, any ideas on how to fix this?
Flags: needinfo?(jlal)
Ok, I followed up with James about this. The marionette.js code that this test is depending on is the old integration test framework which James Lal and team have now replaced. Julien is the person tasked with updating the gaia make test-perf target to use the new JS integration test framework which should fix this bug.  I'll flag Julien to ensure I have all this correct and for him to provide an ETA on when he thinks he'll have time to fix this.
Flags: needinfo?(jlal) → needinfo?(felash)
So, I had a preliminary patch in bug 912541. There was a final problem where marionette was closing the connection before I could delete the session.

In the end, I created bug 915156 and bug 915158 to handle the new work.

But if you know well marionette you can try finish my patch in bug 912541, so that at lesat they'll work until we port it to the new marionette framework.
Flags: needinfo?(felash)
Blocks: 916017
Whiteboard: [c= ] → [c=automation p= s= u=]
Thanks!
Target Milestone: --- → 1.2 C3(Oct25)
Assignee: nobody → hub
Whiteboard: [c=automation p= s= u=] → [c=automation p=3 s= u=]
No longer blocks: 916017
Depends on: 915156
Depends on: 915158
No longer depends on: 915156
Target Milestone: 1.2 C3(Oct25) → 1.2 C5(Nov22)
After further analysis, this is just a dupe of bug 915156, bug 914541, etc.

This no longer occur with the branch work for bug 915156. Marking as such. Feel free to open a new bug it things fail once bug 915156 lands, which is supposed to be soon.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Target Milestone: 1.2 C5(Nov22) → 1.2 C3(Oct25)
Duplicate of bug: 915156
Target Milestone: 1.2 C3(Oct25) → 1.2 C5(Nov22)
Whiteboard: [c=automation p=3 s= u=] → [c=automation p= s= u=]
You need to log in before you can comment on or make changes to this bug.