Last Comment Bug 888158 - Make configure to detect Visual Studio 2013 compiler
: Make configure to detect Visual Studio 2013 compiler
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows 8
: -- normal (vote)
: mozilla25
Assigned To: Xavier Fung
:
: Gregory Szorc [:gps]
Mentors:
: 872028 (view as bug list)
Depends on:
Blocks: 888159 VC12
  Show dependency treegraph
 
Reported: 2013-06-27 22:56 PDT by Xavier Fung
Modified: 2014-02-17 18:17 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for VS2013 (4.81 KB, patch)
2013-06-27 22:57 PDT, Xavier Fung
ted: review+
Details | Diff | Splinter Review
Updated patch (5.47 KB, patch)
2013-07-02 10:55 PDT, Xavier Fung
no flags Details | Diff | Splinter Review

Description Xavier Fung 2013-06-27 22:56:26 PDT
I have hacked some of the configure files to detect the compiler from Visual Studio 2013 (VC12). See if this is helpful.
Comment 1 Xavier Fung 2013-06-27 22:57:20 PDT
Created attachment 768771 [details] [diff] [review]
Patch for VS2013
Comment 2 Ted Mielczarek [:ted.mielczarek] 2013-07-02 06:55:42 PDT
Comment on attachment 768771 [details] [diff] [review]
Patch for VS2013

Review of attachment 768771 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/installer/removed-files.in
@@ +1448,5 @@
> +    msvcr120.dll
> +    #ifdef MOZ_METRO
> +      vccorlib120.dll
> +    #endif
> +  #endif  

nit: trailing whitespace

::: configure.in
@@ +500,5 @@
> +        elif test "$_CC_MAJOR_VERSION" = "18"; then
> +            _CC_SUITE=12
> +            _MSVS_VERSION=2013
> +            AC_DEFINE(_CRT_SECURE_NO_WARNINGS)
> +            AC_DEFINE(_CRT_NONSTDC_NO_WARNINGS)            

nit: trailing whitespace

While you're here, how about moving the AC_DEFINEs outside of the if blocks, since they're defined for all versions of MSVC we support now?

::: js/src/configure.in
@@ +494,5 @@
>              AC_DEFINE(_CRT_NONSTDC_NO_WARNINGS)
> +        elif test "$_CC_MAJOR_VERSION" = "18"; then
> +            _CC_SUITE=12
> +            AC_DEFINE(_CRT_SECURE_NO_WARNINGS)
> +            AC_DEFINE(_CRT_NONSTDC_NO_WARNINGS)    

same comment here as the other configure.in.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2013-07-02 07:00:38 PDT
Thanks for the patch!
Comment 4 Xavier Fung 2013-07-02 10:55:45 PDT
Created attachment 770291 [details] [diff] [review]
Updated patch
Comment 6 Ryan VanderMeulen [:RyanVM] 2013-07-03 11:31:58 PDT
https://hg.mozilla.org/mozilla-central/rev/a52babf286bc
Comment 7 Masatoshi Kimura [:emk] 2014-02-17 18:17:03 PST
*** Bug 872028 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.