Closed Bug 888336 Opened 7 years ago Closed 7 years ago

chat title not displayed after tearing off and reattaching a chat window

Categories

(Firefox Graveyard :: SocialAPI, defect)

defect
Not set

Tracking

(firefox24 verified, firefox25 verified)

VERIFIED FIXED
Firefox 25
Tracking Status
firefox24 --- verified
firefox25 --- verified

People

(Reporter: florian, Assigned: florian)

References

Details

Attachments

(3 files, 1 obsolete file)

Attached patch Patch (obsolete) — Splinter Review
At first this looked like a trivial missing setAttribute call, but it turned out there were several issues:
- first, the swapDocShells method wasn't called with the right parameter and 'this' values when reattaching.
- then, the title was displayed correctly, but the window from which we were moving the docShell didn't close itself any more because of an exception when removing a webProgressListener (in socialErrorListener.remove).
- and finally, when I wanted to test this, my test failed intermittently because the "got-chatbox-visibility" message is sometimes received once, sometimes twice (I guess the order in which the events related to destroying the old window, and loading the new one aren't fired in a deterministic order). I wonder if this (especially the swap.click() call in there) could have been causing other less visible intermittent failures.
Attachment #768990 - Flags: review?(mixedpuppy)
(bug 886086 had changed browser_chat_tearoff.js since my last mozilla-central update.)
Attachment #768990 - Attachment is obsolete: true
Attachment #768990 - Flags: review?(mixedpuppy)
Attachment #769667 - Flags: review?(mixedpuppy)
Attachment #769667 - Flags: review?(mixedpuppy) → review+
https://hg.mozilla.org/mozilla-central/rev/acc55dc38b38
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Comment on attachment 769667 [details] [diff] [review]
Unbitrotted patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 880911
User impact if declined: Some brokenness on detached and then reattached SocialAPI chat windows. The most visible one is the lack of title in the floating window's title bar.
Testing completed (on m-c, etc.): Test included in the patch; landed on m-c a few days ago.
Risk to taking this patch (and alternatives if risky): low.
String or IDL/UUID changes made by this patch: none.
Attachment #769667 - Flags: approval-mozilla-aurora?
Comment on attachment 769667 [details] [diff] [review]
Unbitrotted patch

low risk patch that helps fix a user visible bug when user is trying to use the new feature (tearing-off of chat  windows in Social). Approving on aurora.
Attachment #769667 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Keywords: verifyme
Samvedana, can you please verify this is fixed in Firefox 24 and 25?
QA Contact: samvedana.gohil
Attached image tear off window.PNG
User Agent :Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:25.0) Gecko/20130723 Firefox/25.0
Build ID: 20130723030205

Tested this on Windows 8 using latest nightly. I don't see any issues. Both windows were showing chat title.
See attached screen shots.
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20130723 Firefox/24.0
Build ID: 20130723004004

Tested this on Windows 8 using latest Aurora. I don't see any issues. Both windows were showing chat title.
Status: RESOLVED → VERIFIED
Keywords: verifyme
I backed this out and re-landed it on beta so that I could more easily uplift the fixes for bug 886072 and bug 886086. There should be no functional change - it's just reordering a couple commits.

https://hg.mozilla.org/releases/mozilla-beta/rev/8fb54e7478ef
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.