nsBrowserContentHandler should use the search service's async initialization API

RESOLVED DUPLICATE of bug 1492475

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1492475
6 years ago
a month ago

People

(Reporter: Gavin, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
Posted patch patchSplinter Review
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
This breaks stuff because the command line handler now no longer opens a window synchronously, and so Firefox shuts down before the callback is triggered. Not sure offhand how to prevent that.
Assignee: gavin.sharp → nobody
Flags: firefox-backlog+
(In reply to :Gavin Sharp [email: gavin@gavinsharp.com] from comment #2)
> This breaks stuff because the command line handler now no longer opens a
> window synchronously, and so Firefox shuts down before the callback is
> triggered. Not sure offhand how to prevent that.

Services.startup.exitLastWindowClosingSurvivalArea(); ?
(In reply to Florian Quèze [:florian] [:flo] from comment #3)

> Services.startup.exitLastWindowClosingSurvivalArea(); ?

I meant enterLastWindowClosingSurvivalArea() of course, but they both go together anyway.
Status: ASSIGNED → NEW
Component: General → Search
Priority: -- → P3

Fixed in bug 1492475 or maybe others)

Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1492475
You need to log in before you can comment on or make changes to this bug.