Windows desktop B2G build failure during webapp.zip packaging

VERIFIED FIXED

Status

--
blocker
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: RyanVM, Assigned: ochameau)

Tracking

unspecified
x86
Windows 7
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:hd+, b2g-v1.1hd fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Since we don't run dep builds for Windows builds (see bug 879370), all I can do is provide a regression range between the last good nightly and the broken one. I assume that someone will look into this promptly since these builds were deemed of high enough value to continue running. I also assume that nobody will object to mozilla-central remaining closed due to this even if bug 888765 is resolved in the mean time.
https://hg.mozilla.org/integration/gaia-central/pushloghtml?fromchange=c201d63425a6&tochange=b781d1e14fd8

https://tbpl.mozilla.org/php/getParsedLog.php?id=24829368&tree=Mozilla-Central

b2g_mozilla-central_win32_gecko nightly on 2013-07-02 04:46:04 PDT for push 4ffb23062b3b
slave: w64-ix-slave109

run-js-command  webapp-zip
make[7]: Leaving directory `/e/builds/moz2_slave/m-cen-w32_g-ntly-0000000000000/build/gaia'
e:\builds\moz2_slave\m-cen-w32_g-ntly-0000000000000\build\obj-firefox\b2g\gaia\Makefile:38:0: command 'make -j1 -C e:/builds/moz2_slave/m-cen-w32_g-ntly-0000000000000/build/gaia profile' failed, return code 2
e:\builds\moz2_slave\m-cen-w32_g-ntly-0000000000000\build\config\makefiles\target_libs.mk:59:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-cen-w32_g-ntly-0000000000000/build/build/pymake/pymake/../make.py -C gaia libs' failed, return code 2
e:\builds\moz2_slave\m-cen-w32_g-ntly-0000000000000\build\config\makefiles\target_libs.mk:17:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-cen-w32_g-ntly-0000000000000/build/build/pymake/pymake/../make.py -C b2g libs' failed, return code 2
evaluation from e:\builds\moz2_slave\m-cen-w32_g-ntly-0000000000000\build\config\rules.mk:746:24:23:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-cen-w32_g-ntly-0000000000000/build/build/pymake/pymake/../make.py libs_tier_app' failed, return code 2
e:\builds\moz2_slave\m-cen-w32_g-ntly-0000000000000\build\config\rules.mk:680:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-cen-w32_g-ntly-0000000000000/build/build/pymake/pymake/../make.py  tier_app' failed, return code 2
e:\builds\moz2_slave\m-cen-w32_g-ntly-0000000000000\build\client.mk:372:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-cen-w32_g-ntly-0000000000000/build/build/pymake/pymake/../make.py -j4 -C obj-firefox' failed, return code 2
e:\builds\moz2_slave\m-cen-w32_g-ntly-0000000000000\build\client.mk:172:0: command 'C:/mozilla-build/python27/python.exe e:/builds/moz2_slave/m-cen-w32_g-ntly-0000000000000/build/build/pymake/pymake/../make.py -f e:/builds/moz2_slave/m-cen-w32_g-ntly-0000000000000/build/client.mk realbuild' failed, return code 2
build/utils.js:76: TypeError: dir is undefined
make[7]: *** [webapp-zip] Error 3
(Reporter)

Comment 1

5 years ago
Oh, and the corresponding Gecko regression range.
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d7553251cf43&tochange=4ffb23062b3b
Alex, think you can take a look at this?
Assignee: nobody → poirot.alex
Looking at where this is breaking this is almost certainly fallout from this gaia change:
https://github.com/mozilla-b2g/gaia/commit/e8191ba03a24507303515c58a61532868306fa8e#build/webapp-zip.js
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #3)
> Looking at where this is breaking this is almost certainly fallout from this
> gaia change:
> https://github.com/mozilla-b2g/gaia/commit/
> e8191ba03a24507303515c58a61532868306fa8e#build/webapp-zip.js

That's right. And not the first time we get bitten by people using / in path and breaking windows builds :(
(Reporter)

Comment 5

5 years ago
Which begs the question of what revision we're actually building off since gaia.json and the logs say we're building off one that was prior to e8191ba03a24507303515c58a61532868306fa8e.
(Assignee)

Updated

5 years ago
Blocks: 887742
(Assignee)

Comment 6

5 years ago
Created attachment 770278 [details]
Pull request 10748

If I understood original patch correctly, that should fix this exception while doing the exact same thing.
Attachment #770278 - Flags: review?(timdream)
(Reporter)

Comment 7

5 years ago
CCing aki. If PR10748 does fix this, that tells me that the Windows nightly b2g build wasn't actually using gaia.json like it claims to have been, which scares me :)
Comment on attachment 770278 [details]
Pull request 10748

Thanks!
Attachment #770278 - Flags: review?(timdream) → review+
(Assignee)

Comment 9

5 years ago
master: c8f3474fb73dfe2177ec908f0dcf914d7260248e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Rex, please uplift this with bug 887742, thanks.
blocking-b2g: --- → hd?
status-b2g-v1.1hd: --- → affected
Flags: needinfo?(rexboy)
hd+ as required by bug 887742
blocking-b2g: hd? → hd+
v1.1hd: 43029b5a4743bb90280cd17901e7118aa26332c9
status-b2g-v1.1hd: affected → fixed
Flags: needinfo?(rexboy)

Updated

5 years ago
Depends on: 902185

Updated

5 years ago
No longer depends on: 902185

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.