Last Comment Bug 889501 - Purchasing pricetier 0 app for anonymous users fails with a 500
: Purchasing pricetier 0 app for anonymous users fails with a 500
Status: RESOLVED FIXED
:
Product: Marketplace
Classification: Server Software
Component: Consumer Pages (show other bugs)
: 1.0
: All All
: -- major (vote)
: 2013-07-04
Assigned To: Christopher Van Wiemeersch [:cvan]
:
Mentors:
Depends on:
Blocks: marketplace-payments
  Show dependency treegraph
 
Reported: 2013-07-02 11:45 PDT by krupa raj[:krupa]
Modified: 2013-07-04 01:01 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description krupa raj[:krupa] 2013-07-02 11:45:39 PDT
steps to reproduce:
1. Tester is not logged in
2. Find a price tier app on marketplace-dev (https://marketplace-dev.allizom.org/app/test-app-jgkjg/)
3. Click on the purchase button

expected behavior:
user is prompted to sign in within a trusted UI

observed behavior:
Install fails with "Error communicating with the server..."

headers:
03 E/GeckoConsole(  506): Content JS LOG at https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=1b0d9ae-51d31264:1 in anonymous: [req] Request failed:  INTERNAL SERVER ERROR
07-02 11:40:33.403 E/GeckoConsole(  506): Content JS LOG at https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=1b0d9ae-51d31264:1 in anonymous: [req] Error message:  Cannot assign None: "AddonPurchase.user" does not allow null values.
07-02 11:40:33.403 E/GeckoConsole(  506): Content JS ERROR at https://marketplace-dev-cdn.allizom.org/media/fireplace/js/include.js?b=1b0d9ae-51d31264:1 in anonymous: [install] Error installing app:  Could not generate receipt
Comment 1 krupa raj[:krupa] 2013-07-02 11:45:59 PDT
ashes: 537a1
Comment 2 Christopher Van Wiemeersch [:cvan] 2013-07-02 13:05:39 PDT
https://github.com/mozilla/fireplace/commit/3ee43d6
https://github.com/mozilla/fireplace/commit/a87668a

The API should never 500 from bad data - we should probably file separately for that though.
Comment 3 krupa raj[:krupa] 2013-07-02 13:28:34 PDT
Now, there is no 500 and the user is logged in but the install doesn't start after logging in.
Comment 4 krupa raj[:krupa] 2013-07-02 13:30:42 PDT
(In reply to krupa raj[:krupa] from comment #3)
> Now, there is no 500 and the user is logged in but the install doesn't start
> after logging in.

ashes ID: c37e2
Comment 5 Christopher Van Wiemeersch [:cvan] 2013-07-02 14:10:57 PDT
https://github.com/mozilla/fireplace/commit/80353ee
Comment 6 Iulian Timis 2013-07-03 04:23:49 PDT
The user is now prompted to sign in via Persona, but the app install fails, and the following message is displayed "Install failed. Please try again later."
Log ID: 9f7a7
Comment 7 Christopher Van Wiemeersch [:cvan] 2013-07-03 10:43:13 PDT
Works for me - can someone verify please?
Comment 8 krupa raj[:krupa] 2013-07-03 11:55:48 PDT
wfm too

Iulian, what server were you testing this on and what app did you use?
Comment 9 Iulian Timis 2013-07-04 01:01:21 PDT
(In reply to krupa raj[:krupa] from comment #8)
> wfm too
> 
> Iulian, what server were you testing this on and what app did you use?

I used the app from the STR https://marketplace-dev.allizom.org/app/test-app-jgkjg/ on MP-dev app on Unagi

Note You need to log in before you can comment on or make changes to this bug.