Usage information does not show in notifications

VERIFIED FIXED

Status

Firefox OS
Gaia::Cost Control
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: marcia, Assigned: salva)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+, b2g18? verified, b2g-v1.1hd fixed)

Details

(Whiteboard: [LeoVB+], URL)

Attachments

(6 attachments)

Created attachment 770491 [details]
Screenshot of empty usage area when notifications are pulled down

Leo device, while using - happens on Unagi as well using the same build:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/01eacfdb4793
Gaia   0d5a9a7577f16b6a72a982148c6f509ee1714ea2
BuildID 20130702070214
Version 18.1

STR:
1. Pull down notifications
2. Observe no data shows
3. Go to usage app - observe that data shows

Screenshots attached
Created attachment 770492 [details]
Data showing in usage app
Nominating for blocking.
blocking-b2g: --- → leo?
(Reporter)

Updated

5 years ago
OS: Android → Gonk (Firefox OS)
Broken:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/8d883cb49438
Gaia   6ed9316f397dfe09d8fa88506881d1a4e697643a
BuildID 20130629230208
Version 18.1

Works:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/8d883cb49438
Gaia   c9e9b09cb181fcd15d12af09f89ff87f553c06c7
BuildID 20130628070211
Version 18.1
Keywords: regressionwindow-wanted
Assignee: nobody → gduan
In addition to this issue, there is also an issue in usage settings where you are not able to save any of your settings when selecting "Done." I assume it is part of the same issue since it is not seen in the "Works" build in Comment 4.
Comment on attachment 770658 [details]
https://github.com/mozilla-b2g/gaia/pull/10759

I prefer to keep the balance undefined as it is not mandatory. Anyway, this is already resolved in bug 888206.
Attachment #770658 - Flags: review?(salva) → review-
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 888206

Comment 9

5 years ago
This bug is due to the below(from v1train code)

[JavaScript Error: "TypeError: ConfigManager.configuration.balance is undefined" {file: "app://costcontrol.gaiamobile.org/js/widget.js" line: 109}]

So need to be uplifted to v1train.
Status: RESOLVED → REOPENED
Flags: needinfo?(salva)
Resolution: DUPLICATE → ---

Updated

5 years ago
blocking-b2g: leo? → leo+

Comment 10

5 years ago
Thanks Leo.

This isn't a duplicate because 888206 is resolved and this bug is still occurring.
Ok, I see. Indeed, the problem is the same but it was happening in two different places. Anyway, the solution is not adding a default value for balance object as it is valid to not have a balance section at all. The solution must be to not initialize the BalanceView when there is not balance section.
Assignee: gduan → salva
Flags: needinfo?(salva)

Updated

5 years ago
Flags: in-moztrap?(cbarker)
Created attachment 771623 [details]
Avoid startup error
Attachment #771623 - Flags: review?(francisco.jordano)
Comment on attachment 771623 [details]
Avoid startup error

Damn it, we missed this in bug 888206, anyway the fix is pretty straight forward and works perfectly.

Thanks Salva.
Attachment #771623 - Flags: review?(francisco.jordano) → review+
Master: 9e3fc3bbbd07454644a911f1a60095e1d085ad07
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 17

5 years ago
I can reproduce this again on v1-train on Unagi with today's build:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/f917f3fb17ab
Gaia   4d6b55ce05cfd94474946cbefc87fc1ecc930d21
BuildID 20130708230204
Version 18.0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

5 years ago
Created attachment 772625 [details]
screenshot 07/09
Teodosia, this patch has not been backported yet to b2g18. It's only fixed on master. So lets see that we can get this backported. Setting the flags accordingly.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
status-b2g18: --- → affected
tracking-b2g18: --- → ?
Resolution: --- → FIXED
Uplifted 9e3fc3bbbd07454644a911f1a60095e1d085ad07 to:
v1-train: 878476f9e8b47c9398f847304d9387fa9fd23b92
status-b2g18: affected → fixed

Comment 21

5 years ago
Verified fixed on v1-train.

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/b64372810dd7
Gaia   680c72ccbd2d5045e590a6ba08de2aac6af71953
BuildID 20130710230201
Version 18.0
Status: RESOLVED → VERIFIED

Updated

5 years ago
status-b2g18: fixed → verified

Updated

5 years ago
Whiteboard: [LeoVB+]
v1.1.0hd: 878476f9e8b47c9398f847304d9387fa9fd23b92
status-b2g-v1.1hd: --- → fixed
You need to log in before you can comment on or make changes to this bug.