fallback to custom characters in Private Use Area if user-defined font does not include them

RESOLVED DUPLICATE of bug 789788

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 789788
5 years ago
5 years ago

People

(Reporter: Frank Tobin, Unassigned)

Tracking

22 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

Uncheck "Allow pages to choose their own fonts, instead of my selections above".
Visit a site using Private Use Area characters with a custom font, such as https://github.com


Actual results:

PUA characters are not rendered.  For example, see the upper-right controls on https://github.com


Expected results:

The PUA characters should have been rendered with the custom/downloaded font the site defined.

For any user disabling "Allow pages to choose their own fonts", it makes sense to gracefully fail back to characters the site has defined for the PUA range.

I'll note this request may slightly conflict with Bug 399369, which requires "Disable font fallback when a character is in the private use areas."  Since PUA characters are prevalent, it does not make sense to make them usable if the site defines them.  Instead, not rendering characters causes the user to choose between not using the site or re-checking  "Allow pages to choose their own fonts" as-needed.
I think this is essentially the same as bug 789788, which has some discussion of possible ways forward here (though no firm conclusions at this point).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 789788
You need to log in before you can comment on or make changes to this bug.