Closed Bug 889947 Opened 7 years ago Closed 7 years ago

[B2G][l10n][Settings-Memory] The warning message about changing a media drive is not localized

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:leo+)

RESOLVED WORKSFORME
1.1 QE4 (15jul)
blocking-b2g leo+

People

(Reporter: sarsenyev, Assigned: kaze)

Details

(Keywords: l12y)

Attachments

(1 file)

Description:
When changing a media drive (SD-Internal),the warning message in English  and isn't localized to any other target languages

Repro Steps:
1) Updated to Buri/Inari/Leo/Unagi Build ID: 20130621070212
2) In the "Settings" choose any other language but not English
3) In the "Settings" navigate to "Media Storage" category
4) Slide down to the end of page and tap on "Default media lacation option (SD card-Internal)
5) Observe the warning message

Actual:
The warning message in English

Expected:
The warning message in the target language

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a34f6d62cb05
Gaia: cca61224e6df8e9f7e450d77cb6a8cf91029be64
Platform Version: 18.1

Notes:
Repro frequency: 100%
blocking-b2g: --- → leo?
Keywords: l12y
Blocking since it's important for thing to be localizable.
blocking-b2g: leo? → leo+
Kaze, would you mind taking a look?
Assignee: nobody → kaze
Target Milestone: --- → 1.1 QE4 (15jul)
This is related to bug 856782 and bug 888818, both leo+ and uplifted to v1-train.

The l10n key (change-default-location-confirm) can be found in the locales that I tested (French, Spanish, German, Polish)… but I can’t test the message because the “Default media selection” <select> box doesn’t work on my devices — neither with Gaia cca61224 nor with the latest master / v1-train branches. 

Investigating.
I confirm it works on the latest v1-train and master branches: it turns out Gaia version cca61224 does not include the patch we landed for bug 888818. Please update to the latest v1-train version or cherry-pick the related patch.

The reason why I could not see the message is a feature, not a bug: as there’s only one possible choice for the default media location (= “SD Card”), the related <select> box is disabled. I had to tweak the JS a bit to make sure the warning message was properly localized.

sarsenyev: what device should I use to test this? I only get one choice (“SD Card”), I can’t see any “Internal SD Card” option with the devices I tested.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(sarsenyev)
Resolution: --- → WORKSFORME
Tested on Leo Device V1.1, "Internal memory as default, but when you will click on the "change" option the prompt message appears and it's not localized
Flags: needinfo?(sarsenyev)
sarsenyev: again, this bug has been fixed by bug 856782 and bug 888818. If you’re not using the latest master / v1-train branch, please check that the two related patches have been cherry-picked in your branch.
Flags: needinfo?(sarsenyev)
After checking all implemented languages, the warning message is localized on all languages except "Turkish"
Flags: needinfo?(sarsenyev)
You need to log in before you can comment on or make changes to this bug.